It s back, calculating like forever

im not talking about the download after closing the game every time wwhich hasnt been fixed, but every time i start the game it is trying to calculte forever. what s this?

Hey there,

If you are referring to the Preparing Game Data window that appears when you first launch the game, then it would indicate something on the system or network is interfering with the completion of that processes.

You can try restarting the system, disabling any other software that is not needed for the app and game client, as well as restarting your local network to see if that helps solve the situation.

no the problem isnt solved…
sry for the late answer though.
i checked in task manager and the only sus activity is from microsoft compatiblity telemetry which is a system integrated program…
i m using win10 home

1 Like

Howdy Yawgmoth,

Based on what you described, I would suggest a clean reinstall of the Blizzard app:

  1. Open Control Panel.
  2. Click Uninstall a program.
  3. If is listed, right-click on Blizzard app and select Uninstall.
  4. Next let’s delete the temporary files. To find those files, press Windows Key + R and type the following commands, pressing enter after each one to open the folder location. Delete the, Blizzard and Blizzard Entertainment folders in each location:
    • %APPDATA%
    • %TEMP%
  5. Reinstall the app using the download from the page here
  6. Make sure you run as Admin and install onto the C drive if possible.
  7. Restart the Blizzard app and try launching the game again

If you still notice these long delays launching the game, then I suggest creating a support ticket with your system files so this can be investigated.

You know what fix it for me I am such a big brain gamer.I exactly need 20seconds to figure out for to fix this “endless loop update”:
1-launch blizzard app
2-disable internet access
3-launch hots
4-wait 15seconds
5-leave hots
6-enable internet access again
7-launch hots again
8-enjoy playing the game

at most that s a work around and not a fix for the update loop…in that way i could also just use the switcher.exe…
but that wasnt the point of this thread u r way offtopic
anyway i uninstalled hots followed all the steps and even cleaned my reg but calculating time seems to increase with every time i start the game…

Howdy Yawgmoth,

Have you tried setting the HotS game file to run as admin by right-clicking the exe in the game folder and going to Properties? If this keeps happening, try deleting the HotS folder in the Documents to see if there’s any improvement.

yes i did that again right after reinstalling. gonna try some other stuff later.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.