Hots on Catalina OS doesn't work at all

Even the menu it’s bugged. i have to click on everything to get details, instead of just hovering as usual.

Gameplay? worse. Camera doesn’t move at all (No it’s not locked with L) and aiming with abilities doesn’t work as well.

Tried restarting game and laptop, no fix. There shouldn’t be no need for me to re-install the whole game again so patch it up ASAP, thanks.

Also, voice chat doesn’t work too! Can’t find a way to give Hots permission to use my mic, but I can give permission to the Blizz client for some reason.

Try tab out then tab in (command + tab), it seems to be a full screen bug

wow… just did it on the menu and seems to be working for now. guessing it’ll work in-game as well, thanks

Hey, knightmare! There’s actually a few different issues for Heroes of the Storm that we’re aware of. We have them listed here:

For the voice chat issues on Catalina, there’s a thread here about the issue. It’s quite advanced and not something that we can directly support as it requires changing some things using the terminal.

A lot of these are bugs that our team needs to work on and some requiring some work with Apple as well. As technical support, we try to keep everyone in the loop regarding the issues when we receive updates, but we are not the developers or directly apart of the Heroes of the Storm team. We only help with technical issues that can be resolved through troubleshooting.

Since this is the technical support forums, the Heroes team may not check it as often as they do the other forums. It’s frustrating, but please feel free to voice your concerns regarding any bugs on #bug-report forums or the #general-discussion for any feedback!

Having trouble with scrolling in the game. Setting are same as they have always been but its like my screen is locked. Also cannot scroll through skins for character skins. Tried not being in full screen mode, it was better but still not playable