"Connection to Voice Service Lost" Multiple Times a Game Causing 3-5 Second Lag Spikes

Hi there,

I recently bought a brand new PC, and have been troubleshooting a variety of frustrating latency issues that only happen in HotS (issues that do not happen on my old PC, or my wife’s PC, all connected to the same network via ethernet). However, after an insane amount of Googling and disabling dozens of features and services in Windows 10, I believe I’m down to one final issue:

Multiple times a game, I experience a sudden lag spike of around 3-5 seconds (the game freezes, then quickly “catches back up” with what happened). Prior to my previous troubleshooting, this used to happen for no reason, with zero indication of why. However, I now see a “Connection to Voice Service Lost” message appear whenever this happens. A few seconds after the lag spike, I get a message about voice services reconnecting.

The following WinMTR was captured in the first two-three minutes of a Quick Match game, where the issue happened twice. I’m not an expert on this stuff, but it appears that the " xe-0-0-1-1-br02-eqla1DOTas57976DOTnet" server might be the culprit? Any advice or help on this is appreciated, as HotS has been my favorite game since Alpha, and I would really like to be able to play with my wife again without these issues. Thanks!


|                                      WinMTR statistics                                   |

|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |


|                    -    1 |  137 |  136 |    0 |    0 |    8 |    0 |

|                           96.XX.XX.XX-    4 |  125 |  121 |    8 |   11 |   29 |   16 |

|                          96.XX.XX.XX-    4 |  125 |  121 |    9 |   13 |   56 |   15 |

|ae-2-ar01.sacramento.ca.ccal.comcast.net -    4 |  125 |  121 |    9 |   13 |   35 |   19 |

|be-33667-cr02.sunnyvale.ca.ibone.comcast.net -    4 |  125 |  121 |   12 |   16 |   33 |   20 |

|be-21025-cr01.9greatoaks.ca.ibone.comcast.net -    4 |  125 |  121 |   13 |   17 |   34 |   13 |

|be-12544-pe01.9greatoaks.ca.ibone.comcast.net -    4 |  125 |  121 |   12 |   15 |   32 |   18 |

|                 -    4 |  125 |  121 |   13 |   19 |   75 |   20 |

|              ae1-br02-eqsv5.as57976.net -    4 |  125 |  121 |   19 |   24 |   65 |   25 |

|       xe-0-0-1-1-br02-eqla1*as57976*net -    0 |  140 |  140 |   19 |   33 |  186 |  112 |

|                  -    4 |  125 |  121 |   20 |   24 |   71 |   25 |

|        lax-eqla1-ia-bons-03.as57976.net -    1 |  137 |  136 |   20 |   23 |   36 |   21 |

|                  -    2 |  133 |  131 |   19 |   21 |   37 |   28 |


Hey, smi1ey! Thank you for including the WinMTR tests and details here.

The problem isn’t on the xe-0-0-1-1-br02-eqla1.as57976.net. The average latency is fine, oddly though there is no packet loss either. The test is a bit short than preferred, but it is showing the problem starting at the system or home network with a 1% packet loss here. There’s a consistent 1-4% loss throughout the test. These losses do not appear to be legitimate loss, so mitigation is the prime concern causing the issue.

With this only happening on the new PC and all the other systems on the home network are fine, it’s more than likely a system network issue like network protocols or network adapter issue.

Since it is wired and likely to the network adapter on the motherboard, would you have a different network card or wireless that’s an option to test? This should help narrow down the concern.

There’s a few additional steps that may help address the system network concerns.

  • If on Windows 10, reset the network settings.

    1. Click on the Start Menu
    2. Select on the Settings :gear: option.
    3. In the Windows Settings, click on “Network & Internet”
    4. Near the bottom of the new window, click on “Network Reset”

    Try again, and if it persists, try rebooting to help with the changes made from the Network Reset.

  • Check for network driver updates from the manufacturer.

  • If you have a Dell system, try checking for Smartbyte by Rivet Networks in the Apps & Features. If you have an HP Omen system, try checking for the HP Omen Network HSA service in the services window (Search for services.msc in Windows).

  • Check for mitigation or prioritization of the home network. This can affect specific devices or connection types. In the router, check the following settings are disabled

    • QoS (Quality of Service)
    • WMM (Wireless Multimedia)
    • UPnP (Universal Plug and Play)

    The settings for these can vary from depending on the device model. It’s not something that we help with directly because the settings and locations can vary. The router manufacturer or Internet Service Provider (if the router/modem was provided by them) can help look for these settings.

If the problem continues, could you run a new WinMTR test for 10-15 minutes to see if we can get a bit more data on the connection?

Thank you for the detailed reply! I’ve tried most of the steps you mentioned already, and I’m starting to think the issue is the ethernet adapter as well. I’ve read many posts about how bad “Killer” branded ethernet adapters are for gaming, and unfortunately I had no other option while configuring my Alienware system. I’m immediately starting to regret not just building my own PC as I’ve done in the past, but too late now.

I feel dumb, but until now I completely forgot that my PC came with a wireless card (if available, ethernet is a no-brainer for gaming, so I didn’t even think about playing HotS via wireless). I’m going to test some games using wireless to see if I run into the same issues. If I don’t, I think it’s safe to assume the hardware itself is bad, which is a shame because it’s part of my MB. I’ll reply with my findings either way, and will post a new, longer WinMTR readout if the issues continue via wireless.

UPDATE: Apparently I can’t reply to my own post… so here’s an update. I played 5 games in a row yesterday while on wi-fi and experienced zero lag. I hope that the issue is simply with this specific ethernet adapter and not the “Killer” brand as a whole, but at least this gives me some ammo to reach out to Alienware support. For the record, my wireless adapter is also Killer-branded, but in my research it appears their ethernet adapters are the cause of most people’s issues. Thanks again for the response, and I’ll post a final update if I learn anything new in case people in the future find this post. I know that older posts from this forum and Reddit were a huge help to my initial troubleshooting of this issue. Cheers!

Hey, smi1ey! I really appreciate all the details here. As an additional suggestion, a different ethernet cable may be worth testing. Sometimes, ethernet cables can get damaged if they are messed with a lot or if they were damaged from something like vacuuming while the cables were on the floor.

In additional to killer, while it doesn’t seem to be related to killer specifically. We have seen some problems before. Usually updating the network drivers should do the trick, but the following steps can help as well:

  1. Open Killer Control Center (can be done from windows search)
  2. Click the settings cogwheel in the bottom left
  3. Disable Advanced Stream Detect
  4. Retest

I’m glad that the wireless connection seems to have helped in this situation :slight_smile: If you find anything, we’d appreciate sharing the details here in case someone else runs into similar issues!

Wow I honestly wasn’t expecting another response, so thank you! I tested the same ethernet/network setup with my old PC after I had issues with the new one, and there wasn’t an issue, which basically completely isolates to the new hardware. I also tried reinstalling the network drivers even though the latest ones were already installed. As for Killer software, I actually fully removed all of the proprietary software and services as research showed that these can cause many issues. The interesting thing is, after removing the Killer software/services (which took multiple tries with their uninstaller, as well as manually removing) the issue went from just random lag spikes, to the issue I described above that relates specifically to voice services. Same lag spikes, but after disabling Killer software/services I started getting that specific voice service error in HotS at least.

All that said, after reading your post I did some research about advanced ethernet adapter settings in Windows 10, and found both a proprietary guide and an official Killer guide about how to configure their adapters. (I apparently can’t include URLs in my post, so Google “Killer ethernet optimize” for the guide on their website.) Both these guides seemed to agree on disabling a whole bunch of CPU offload settings in addition to other settings that essentially force the network card to do more work if you don’t have a great CPU. I decided to follow the entire Killer guide, disabling a ton of the available Killer E2500 adapter settings in Windows 10.

The result? I just played my first ethernet game of HotS with zero lag spikes and zero voice service errors! I have had random lag-free games in the past via ethernet, so I’m going to have to test some more games after work, but I will make a final update if the issue seems to be resolved! Thanks again for all the help, and I hope other people in my shoes with Killer ethernet adapters stumble across this thread in the future!

UPDATE: I just played 5-6 more games… absolutely zero issues. I went ahead and marked this as solved, and will update if the issue returns in the next couple days. Otherwise, if this post doesn’t have an update, I’ll consider it resolved by the following steps:

  • Removing ALL Killer software (like the control center) and services (via services.msc) via the uninstaller they provide on their support site. (Had to run multiple times.)
  • Using Killer’s guide (Google “Killer ethernet optimize”) to disable a large number of advanced settings for the Killer E2500 ethernet network adapter in Windows 10 Control Panel.


Glad to hear that you were able to find the source of the issue, smi1ey! Thank you for sharing :slight_smile: If it seems to come back, let us know!

1 Like