Connection issues. Can only play 5 mins per game

Hey there!
First time poster, 5 year hots player :slight_smile:
I’ve had this issue in the past, but it’s been 4 days in a row and I need some assistance.
Everything works fine until I get into an actual match, whether it’s ranked, unranked, or quick match.
But, after a few minutes, usually no more than 5, the hand starts lagging, and then I’m sent to the reconnecting screen for 5-10 minutes.
Then, I get to play for maybe 2 or 3 minutes before it disconnects again, and I’m back on the reconnecting screen, usually until the end of the match.
I’ve reset, reinstalled, refreshed and renewed things and it hasn’t helped.
In the past when this would happen, I would have no choice but to accept it was out of my hands and wait until it worked again.
Is there anything else I can do on my end?
I’m hard wired into my internet, my connection is great and I don’t know what else it could be.
Any help or advice would be greatly appreciated.

Hey, Jorgon! Welcome to the forums, we’re glad to have you here and help out with the issue :slight_smile:

Based on the behavior of this seemly to be a fairly consistent issue to happen to you, it does sound like there is a connection routing issue to the Heroes game servers. This wouldn’t impact all of the connection, only an issue with Heroes of the Storm if there is a peering or local network issue impacting the connection for Heroes.

Could you provide a WinMTR file? Run the test until the problem occurs for 5 to 10 minutes. This should give us more details on whats happening with the connection from the computer to the game. Copy and paste the text file created and paste it between two ~~~ like so:

WinMTR Here

If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for

1 Like
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|                          hitronhub.home -    0 |  465 |  465 |    5 |   16 |  155 |   18 |
|                     -    0 |  465 |  465 |    9 |   16 |  152 |   16 |
| -    0 |  465 |  465 |    9 |   17 |  153 |   12 |
|    -    0 |  465 |  465 |   11 |   18 |  157 |   16 |
|   -    0 |  465 |  465 |   26 |   34 |  170 |   33 |
| -    0 |  465 |  465 |   26 |   37 |  162 |   35 |
|     -    0 |  465 |  465 |   51 |   61 |  177 |   52 |
| -    0 |  465 |  465 |   51 |   61 |  185 |   58 |
| -    0 |  465 |  465 |   51 |   60 |  177 |   58 |
| -    0 |  465 |  465 |   73 |   90 |  343 |   89 |
|     -    0 |  465 |  465 |   51 |   61 |  178 |   53 |
|                  -    0 |  465 |  465 |   50 |   53 |   65 |   52 |
   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Thank you for the WinMTR test, Jorgon! Was the test ran while the issue occurred? There wasn’t any packet loss on the connection test.

It is showing quite a bit of latency on the home network though:

The average latency is 16ms, which is quite high. For wireless, connections this should be below 10ms, and for wired, it should be around 1ms. The worst latency is spiking quite high as well, at 155ms. With this being a wired connection, there’s likely something on the home network that’s causing the issue like protocols needing a reset or the router experiencing issues.

Could you try these steps?

  • Try a different ethernet cable if available.

  • Reset the network settings:

    1. Right click on your Windows Start Menu, and select “Command Prompt (Admin)” or just search for Command Prompt and right click, run as administrator.
    2. Now type in or copy and paste, “netsh int ip reset” Press Enter.
    3. Then do the same for “netsh winsock reset”

    Once it’s complete, you’ll need to restart the computer to complete the reset.

  • Try an extended powercycle. Instead of unplugging everything for 1 minute, try 30 minutes. This will create a new Session ID with the ISP, rather than connecting to the old one.

  • Reset the router to factory default.

If it continues after these steps, you’ll want to discuss this with the ISP to see if they can check for any issues like the signal and lines of the connection, which wouldn’t show up on a WinMTR test. It’s possible if the router is an older model or one that you’ve had for a few years that it may need replacing.

1 Like

Thank you so much for your help!
Yes, I did run the test while the issues occurred. It actually started lagging right off the bat, so I turned on the WinMTR and kept it on for at least 5-8 minutes, and the reconnecting issues happened for at least 5 of those. I then stopped the WinMTR, and “finished” my game.
Earlier today, I did everything you suggested except for replacing my ethernet cable, and I just played my first full game in a week, without issue :slight_smile:
So that looks like it fixed it! I’ll keep these steps in mind if it starts to happen again.
Thanks again for your help! I’m only 4 wins away from 50, and I was worried I wouldn’t be able to get there before the season ended lol

Thanks for letting us know, glad to hear you were able to enjoy a full match! If the problem comes back we’ll be here.


1 Like

It’s happening again :frowning:
I was able to play a couple games without issue, then I went away for about a week, and when I came back, the same issues were back. In a 25 minute game, I was able to play about 5 minutes at the start before it disconnected, and then another 5 after after 10 minutes of being offline.
This was both with a hard wire connection and on WIFI. Reset my router again, but that didn’t help, so sounds like I need to try another step.
Thanks again

It may be worth a shot doing a factory reset on the device again to see that helps as it did before. If the problem continues to come back after resetting the device, then it might be worth speaking with the ISP about replacing it.

I wish we had better news here. Let us know how things go.

So I haven’t contacted my ISP yet, but I brought my laptop to my work and tried to play there and had the same issues, using different WIFI, but from the same provider as the one I use at home. Not sure if that helps, but I’m starting to think it might be an issue with my laptop not being able to stay connected to the internet, whether it’s wired or WIFI :frowning:

Hey, Jorgon! I appreciate the update and details so far. Based on the initial test, I think you’ve isolated the issue a bit further to the system network. It could be with the protocols or with the network adapter itself.

I’d assume since you’ve already tried wireless and wired, that it’d be using a different network adapter, but update the network card drivers may not be a bad idea. With this in mind though, my main thought is something is up with the system’s network settings like the DHCP lease might be set too long or disabled, or the winsock might not be functioning correctly.

Have you tried running through the network settings steps again to see if that helps alleviate the issue?