Can't authenticate/login to game

Can’t log into the auth servers. Keep getting the same “You were disconnected from Blizzard services” error. Are the servers down or is it a DDOS?


Already thread(s) going for this.

having same issue. Is the fix just waiting?

1 Like

same problem for my GF and I…Takes forever authenticating, then get generic “error code” message.

Side Note: I am able to log into EU servers tho. Not americas


Same issue here. As well as with 2 Friends of mine. Game won’t log in and just gives an Error Code, with no actual code, and fails to authenticate.

1 Like

same for me as well :frowning:

Also having this issue. It says “An Error Occured” and then when I click ok it says I was disconnected from Blizzard services.

I can log into EU though no problem.

I am having same issue of authenticating but then does not login in, but my brother who is in the other room is some how logged in and playing games fine.

Logging in and remaining logged in are two different.

It’s stated this error is fixed but I am still unable to login to game. It keeps timing out during authentication.


I have a problem with Heroes of the Storm log in.

When I launch the Blizzard app I do not need to enter my log-in credentials every time because I have ‘Keep me logged in’ and ‘Remember email addresses’ enabled in my security settings.

It is the same with Hearthstone and Starcraft II – I do not need to enter my log-in credentials every time I want to play, after launching the app and selecting the game of choice I just click PLAY and I enter the game.

With HotS it is different. I enter the app, select HotS and click PLAY. It says Launching… > HotS loading… > Authentication > Connecting… > ERROR – ‘You were disconnected from Blizzard services’ message. Then I have to click OK to get to a HotS log in screen where I can enter my email and password. The region is set to US even though my Blizzard app settings is set on Europe. I change the ‘region US’ to ‘region EU’, then enter my email and password, I have to do this every time I want to paly HotS, then it finally works and I enter the game.

I lose a lot of time because of this situation.

Help me, please.

1 Like

Hello Manage!

I’m thinking there may be old routing data cached in your network hardware, initially trying to send you to the server incorrectly, then getting the correct details on second attempt (but never updating the stored data to the correct ones).

Let’s clear your network hardware’s cached information. It will then automatically check for the latest routing instructions, ensuring an optimized connection:

Power Cycling Your Network Devices

IP Release, Renew, and Flush DNS

Let’s also try clearing the cached data for the app (this won’t affect or remove any installed game files).

Deleting Files

I’d also check if any of your security programs are reacting to the login process. It may be necessary to update your virus definitions, or in extreme cases to temporarily disable such programs.

Troubleshooting Security Applications

Best of luck in your adventures :slight_smile:

I’m having a similar issue as WebDeath & Manage, I have bnet and all games through it remember all my logins and credentials, but when trying to launch hero’s of the storm it says I have no account.
Granted it’s been about a year since I played it, but none of the other bnet games have given me any beef about playing them after similarly lengthy breaks. I’ve tried your fixes but nothing has changed, still gives me a null error and doesn’t recognize my account anymore despite changing nothing about it. Tried contacting support but they’re just giving me the run-around saying it’s something on my end, which is doubtful at best from what I just mentioned above.
Guess the only comfort is it’s not just my problem.