AC Charger disconnecting when playing HOTS


#1

Whenever I launch HOTS, my laptop charger starts disconnecting and reconnecting, apparently at random. This keeps going until my battery runs out, and it even shut off by itself once of twice.
I searched online and found out it might be that my charger is failing, and is not able to supply enough power when my laptop workload increases. The problem with this hypothesis is that it only happens when playing HOTS, and not with any other games. I tried it with Overwatch, SC2, EVE Online and my “mod-it-until-it-crashes” Skyrim, with no similar issues.
I can trace this problem to roughly when they dropped support to the 32 client, which I had used until then. Otherwise the game runs smoothly on Medium, at around 50-60 FPS, with the occasional lag spike due to my unstable internet. I have an Acer Aspire E15, with a Geforce 920M and no other problems so far.
So far I have tried launching HOTS with administrator privileges, without them, with other programs in the background, with no others, using Razer Cortex, changing the graphic settings, and the problem persists. I also have reinstalled HOTS, cleared my Repalys, cleared Firewall settings of duplicate entries, defragged my HD, etc.
If anyone had some other suggestions or input, it would be appreciated.


#2

I had the same issue with my other laptop. I ended up not gaming any more on it because I assumed the charger had failed due to the workload. In retrospect I only experienced the issue with HOTS, not Witcher 3, Skyrim or the like.


#3

Hello Chronos!

This is a puzzling situation, as Heroes is hardly a power hog… have you checked your power management settings, though? If it’s on a low or balanced power profile, the computer may be swapping components on and off in unexpected ways.

Configuring Power Management Settings

Make sure you’re on High Performance when plugged in. If issues persist, let’s take a look at a system report.

Obtaining System Files

You can include the DXDIAG in a reply to the forum post. Place it between rows of ticks (`) for formatting:

```
Like this.
```


#4

Hi,

Out of curiosity did you get this fixed?


#5

I would suggest the usual hardware stat logging tools (HWinfo) and keeping an eye on temperatures.
Maybe feel the area the charger plugs in if it feels particularly warm.