Wont let me open packs

I tried to open a merc pack and it says problem with pack try again later. So now i camt open pack anymorem

I am having the exact same issue. I tried opening on laptop, and also on my phone. Neither worked.

Same issue here, had 90 packs, was opening them normally, at 16 left I got that error, was like one hour ago, since then I cannot open merc packs.

Same. I’m not able to open my mercenary packs. Says try again later…

Same, I managed to open 20 Merc packs when the patch went live but bought another 15 and I am getting the error “there was a problem opening this pack, please try again later”

It has been over an hour since I bought the additional packs.

In known issues:
[Updated 9/27] In Mercenaries, Garona Halforcen is improperly not appearing in Mercenaries Packs. Mercenaries pack opening has been temporarily disabled while this issue is fixed (fix can be done server-side and is expected to go out later today).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.