"There was an error starting your game. Please wait a few minutes and try again." - Duels error

“There was an error starting your game. Please wait a few minutes and try again.” - Duels error

I am not able to play Duels because after building a deck and trying to start my run I receive the above error. I can play all other game types.

I have not joined any Fireside Gatherings. In fact, when I read that this error comes up due to Fireside Gatherings, I actually made a private one for this afternoon to see if that would fix it. It didn’t, and then deleted the event and tried again with no luck.

This was a netdeck that I copied and the game accepted the deck however when I hit play I receive the error. I am unable to retire the run as well.

I’m assuming that the game is bugged and accepted my deck even though there’s a card in there that isn’t allowed right now. I haven’t gone through the whole deck to see yet.

Edit: I just checked every card and all of them are within the sets for the update. I’m at a loss. No idea how to fix this.

Edit 2: I tried a repair and an uninstall/reinstall and they did not fix the issue.

1 Like

This is expected to be fixed with the release of Barrens tomorrow

Barrens just launched and I can’t play any mode except BGs, getting this error.


I’m having the same issue. After several attempts I did get a ranked game to go through, but after it ended I’m back to getting the same error message again. So far ran into it playing Ranked, haven’t tried Duels, but it does appear that BGs are working.


I’m also having the same issue.

The same here. Cannot start a fight, either ranked or not.

Now that Forged in the Barrens has launched, I can’t play. I just get the “error loading, try again later” message. Regular ranked mode.

Don’t use golden cards, it works then for some reason.


This is actually true, just tested it

WIll try, unfortunately my duels deck is locked and I ONLY have golden versions of many of the new legendaries. Still would be better to play anything than nothing.

Tried this and nothing changed, same error. If anything the servers are swamped

Tried the no golden thing, it didn’t work.

1 Like

I tried to play one of the new suggested standard decks in ‘practice’ and it tells me the deck is invalid. So this isn’t even a problem with the servers. There is something wrong with the new cards (I heard it’s core but who knows).

Swapped all golden cards and managed to get in after 2nd time … dunno if it helped.

Having problems starting any tipe of game, in practice even some heroes to choose to play againts show a purple colored box where the names should be and not able to play any type of match so far.

Rdu just said on his stream that both players has to have no golden cards in their decks for it to work. So you can affect it but can’t control what your opponent does.

I’m necro’ing this to add that I had the same problem, and once I checked my collections and fastly went through the various tabs to clear the new card badges (the numbers in the red dots indicating there were newly acquired cards) the problem was gone and the game restarted to work properly. So if you encounter this, just make sure you don’t have any ‘unseen’ new card in your collection.

Twice now that I have played DUEL and it just suddenly say THERE WAS AN ERROR STARTING YOUR GAME PLEASE TRY LATER.

The first time i have to retire which is a waste of PRECIOUS GOLD! It happened to me just now as well, and i dont want to waste gold again. Please resolve and compensate. Thank you.

I cant Even play standard :frowning:

1 Like

Have the same problem( no any fireside gatherings, no unseen cards, not copied deck… i cant even retire - ther’s no any button for this(