"The game was unable to log you in" again

My connection is fine.
I browse other game is fine.
I can browse this forum with no problem

But,
I got “Closed. The game was unable to log you in through Blizzard service. Please wait a few minutes and try again”.

And I have tried that many times, again and again… for more than 15 minutes.

So, I decide to post in this forum, with the expectation of someone can help me fix this issue…
Anyone can help?

Hey there LuckyOwl,

Being told you can’t log in when everything else seems to be connecting just fine is quite odd and frustrating! With it not clearing up and no problems noticed with Hearthstone around the same time, I’m thinking damaged files are to blame, yet a connection issue or interfering program can also cause this.

To start troubleshooting, let’s address possible damaged files. I’m not sure if you’re using a Mac or PC so I’m including both series of steps below that cover deleting a folder with temporary information relating to logging in:

Mac:

  1. Press CMD + Shift + G to open the Go to folder
  2. Navigate to ~/Library/Preferences/Blizzard folder
    If there is no Blizzard or Hearthstone folder, show hidden files and folders by pressing CMD + SHIFT + .
  3. Delete the Hearthstone folder.

Windows:

  1. Press Windows Key + R
  2. Type in %localappdata% and press enter
  3. Go into the Blizzard folder
  4. Go into the Hearthstone folder
  5. Find the Cache folder here and delete it

If clearing out the folder doesn’t help, can we try an alternative connection or even a hotspot or tether with a mobile device?

Please let us know how this goes. Cheers!

Thanks for the help.

Yesterday, finally I was able to login, after trying for 30 minutes.

I don’t know why.
This is not a something I cannot reproduce constantly. Sometimes, I can play the game without any problem, but sometimes, I cannot login too and I have to wait 15+ minutes to login…

I have the exact same problem. I have tried uninstalling, deleting cache for battle.net and hearthstone, using alternative connection. None of it has worked. Problem started just the same when new patch came out.

Same problem here on both PC and iOS. Have not been able to start a game since the latest patch. It’s been a week now. Reinstalling the app did not fix the problem. Is anybody able to play hearthstone at all?

I just uninstalled all blizzard, moving to ff14

Sounds like you used a firewall blocker and it is still blocking. Dont play pirates !

1 Like