Official card website shows nothing for badlands cards

Searching for “hearthstone badlands bandits”, the top google search result is

… but going to that page simply shows

0 cards found for "Standard Cards"

Same for all other badlands cards I have tried to look up.


When I open the link you posted, it shows me the card “The Badlands Bandits”. As expected.
Perhaps it was a momentary glitch?

No, it still shows the "0 cards found for “Standard Cards” message for me.


i have same problem i cant view cards
check my post here

but if for BigHugger site works it means that there are problem somewhere in CDN or DNS , mb that why developers didn’t notice the problem

im from EUrope Italy …

I know cards are there becouse if we use
Legendary · Spell · Showdown in the Badlands · Get eight 3/2 Bandits with bonus effects. Any that can
forum correctly show them

i just want to update , another player opened a thread

and so i did the Edge test and it works , so is not a network related problem like i said before so no CDN/DNS problem …

edit: can you tell what browser/version are you using ??
I have problems with Chrome 119.0.6045.160

I’m using Chrome 119.0.6045.159 (Official Build) (x86_64) on a Mac.

yeah is basically the same version

Stable Channel Update for Desktop
Tuesday, November 14, 2023
The Stable channel has been updated to 119.0.6045.159 for Mac and Linux and 119.0.6045.159/.160 for Windows

Yeah, it must be an issue with specific builds of Chrome.

Just tried it from my Windows PC at work using Firefox, and Chrome (Version 119.0.6045.200 (Official Build) (32-bit)) and it worked fine.

I noticed that using this Chrome, the “0 cards found for Standard Cards” blank page result does appear for a split second, and then is replaced by the card image. Maybe this is a javascript issue?

1 Like

Is there a solution now? Still the same error on 2024/03/07. Google Chrome:122.0.6261.112

Having the same problem for months. Only chrome doesn’t work (version 122.0.6261.112).

Today is working for me , i was not trying everyday so i don’t know when it solved …

Chrome 124.0.6367.119