Latest patch on 8th October makes my mac very sluggish

When i updated hearthstone with the latest patch, that came on 8th October, my games is causing my mac to lag, i use windowed mode, before this patch everything was smooth, now when i launch hearthstone, i cannot browse on the 2nd monitor, because it lags insane.

1 Like

Hey there Avxkim,

I’ve seen a number of reports from players where “Energy Saving” settings in the Apple System Preferences menu can be adjusted which will resolve this error in some cases. I

If this works for you please let us know.

Can you please be more specific about which settings to look at? I’m also having problems with performance after the latest patch (MBP early 2015): very high CPU consumption, fan works like crazy, the game is lagging. The performance is so bad that I’d rather quit the game completely.

I’m playing hearthstone, only when plugged. So it’s not energy saving issue. It’s the latest patch causes very high cpu usage, so my fans ramps up as well with system lags. During the previous patch i could easily play hearthstone in windowed mode, and do other tasks without any issues. By the way, heroes of the storm works well, it’s 100% latest HS patch.

@Lensky, it’s the latest patch ruined HS experience on the mac.

I was also having this issue on 2015 MBP with Retina since the wild cards update. Extreme lag and crazy fans. I saw this fix on Hearthpwn by user Flanderok and it fixed all the lag and fan issue.

Go to Applications-> open Hearthstone folder -> right-click on Hearthstone icon -> get info -> check the box “Launch in low resolution mode (basically disable retina scaling for the app)”.


Could you post a link to this post? It seems like a workaround, not solution. Blizzard should fix this bug.

I am seeing exactly the same on a MacBook Pro (Retina, 13-inch, Early 2015) running High Sierra.

Is it latest patch… or is it Mac OS Catalina?

I upgraded my desktop to Catalina and it is now painfully sluggish in a way the app never has been (in line with reports above).

Meantime, I did NOT upgrade my laptop to the new OS and have been playing Hearthstone smoothly as ever.

So I’m wondering if Catalina might be a problem.

Is mac support - dead? @AmotleyFool, i’ve played HS on Catalina before the patch, i didn’t experienced such issues.

It is the latest patch. I’m having the same issues and my MacBook pro surely surpasses all the Hearthstone requirements. Really hoping for a fix, it’s really no fun to play like this :(!

Hey folks,

For those of you mentioning you still have the problem, several players have gotten good success by fixing their energy saving settings. Please try this and let us know if it does not work.

So what’s the exact thing that needs to be adjusted? Seems a little vague right now. Also, why should this be the fix if that wasn’t the issue BEFORE patch?

@Calbee suggestion helped me to fix the performance, thanks a lot

Hello Drakuloth,

I have the problem as well. Not sure what setting to change in “energy savings” but in any case what changed is the move to the latest patch.

I notice the issue only when playing on the retina display (no issue with a regular hd external monitor, or when I reduce the size of the window on the retina display), which points to the fact that the problem is linked with the way the new HS handles retina displays (clearly differently from before) and explains why Calbee suggestion does work.

Hope you guys can find out what actually changed in the way HS/Unity is using


This was the exact fix that worked for me. What a difference. Thank you, Caldee.

Same here. I have two macs: 2017 MacBook Pro (maxed out), 2014 iMac 5K (i7 + upgraded video card) and both of them struggle mightily with the new Retina-enabled Hearthstone. The only way to get decent frame rates is to use Calbee’s trick to disable Retina resolution completely.

Blizz please fix :slight_smile:

I’d like to echo everyone - the patch has made my CPU usage on my 2015 Macbook Pro (2.7 I5, 8 gig RAM running High Sierra) jump through the rough. I can’t use the computer at all outside playing the game. I’ve put the resolution down, the detail on “low”, but it hasn’t helped enough at all. It’s mostly just jarring how big a change the patch had. Before, I could play a different game on steam, have multiple browsers open, and play hearthstone at the same time. Now opening a google tab is a laggy chore.

Hi guys,

I had the same issue since the patch.
Wish I found this post earlier.
The suggestion from @calbee works.
No longer does your CPU spikes 100%+.
But they should fix this as everyone points out.

Posted about this back in June. Still no fix, which is ridiculous. The tricks mentioned above have not solved the problem for me. WTF Blizzard???

Hi Blizzard,

I am also having the same issue. This happened when Mac released OS Catalina. I don’t think this is an energy saving issue. Most likely something to do with OS Catalina.