Hearthstone stuck on loading screen? Blinking (mobile)

Hearthstone stopped loading, are the mobile servers down? I play on a s20 ultra (sprint/tmobile)

I’ve Uninstalled and re-installed, alongside clearing cache. It won’t load, stuck on loading screen where it’s just blinking blue icon.

I have the same problem on my Kindle Fire HD 8, 7th generation. Also deleted, reinstalled, restarted and it did not help.

Are you getting a prompt to search google drive for progress at login? If so, what happens when you choose no and sign in with your Blizzard info instead?

1 Like

On my Kindle Fire I’m not even getting a prompt. It just goes to the saloon doors and stays there. The blue circle on the top pulsates, but it won’t load beyond that.

As PlayerZ said, I have the exact same issue. It works fine on WiFi but mobile data it doesn’t work, nor load at all stuck at tavern and the blue ring pulses.

does this place help the game to start working, or is it just for reading. I dont see how they can help us get the game going , i have been stuck since the 23rd on my PC

If you are using a 3G or 4G mobile connection then I have some bad news for you. It has been bugged since March and Blizzard refuses to fix it. Try using a VPN or WiFi instead of cellular.

EDIT: I’m afraid this is a duplicate thread, see the link below.

https://us.forums.blizzard.com/en/hearthstone/t/main-thread-cannot-connect-to-hearthstone-on-mobile-data/

I am only using wifi (turned off mobile data, just to be safe). But its stuck for me too.

Phone: S20
Android version: 10

Troubleshooting:

  • Tried both wifi & mobile data
  • Clearing out RAM, currently 3.8 GB available
  • Cleaning out disk space, currently 74.6 GB available

Not sure what else I could try?

I’m on Wi-Fi and it’s not working.
Tablet: Amazon Fire
Version: 5.6.7.0

I’m on a S10 Android v. 10 on AT&T and asks if I want to log in then stuck at the tavern doors with flashing emblem also. And that’s on wifi or 5g connection. And I re downloaded twice, cleared cache twice, with authentication on and off nothing helped.

I am also having problems getting past the entry screen on iMac Catalina. Have uninstalled and reinstalled, going through all the checklists now.

I have the same problem.

I have also had a problem for a while with cards which add something to another card, and a minion gets on board at the same time. Where the red arrow comes and you give, say +1/+1, for another minion, heal etc. I haven´t been able use these cards, where the red arrow comes, for a while now.

So I decided to uninstall yesterday to see if that would solve the problem, but no. And now, I can´t play at all; stuck at loading screen with blue emblem flashing.

Tried clearing app cache and used a wifi, no help.

My phone is Huawei P9 lite, and the game worked fine until now except for the red arrow problem - which in and of itself is a huge problem to say the least.

When I had this on my old iPad it would not work again until I deleted everything and then did a completely fresh dowload and install. A few patches ago it would not let me in either. Tried the same steps again only to find out that the app was no longer supporting my version of iOS.

You could try that. Make sure there is no trace of Hearthstone left on your device. Then go back to the appstore or download it from Amazon.