Hearthstone "play button" missing


#1

usually says play and then says options> and or redeem a code.
Uninstalled both battle.net app and hearthstone and still after fresh install no play or install button on battlenet app.


#2

same problem, I have problems with every game except Destiny 2. Everything was normal yesterday. :tired_face::tired_face::tired_face:


#3

Same problem :frowning:


#4

Heya stoney,

Would it be possible to grab a screenshot of the issue? Basically just grab the picture, toss it online on the platform of your choice, then post it here.

Example: imgur*com/abc123

Note, the asterisk instead of the decimal should allow the link to post.

Thanks!


#8

imgurcom/qS3BDdR
other games are fine within battlenet.app; example below shows the play button with patch ver. (all issues with hearthstone started on wed patch).
imgur
com/0VdqGFY


#9

I’ve got the same problem.


#10

consider yourselves lucky. just find a new game.


#11

I found a temporary solution. Open Windows task manager and quickly end task for Blizzard Update agent and Battle*net Helper. The play button should show up. At least it’s working here.


#12

If you see the advertisement for Dalaran Heist, you should be able to click on the big orange X at the top right corner.

If the advertisement isn’t appearing, security applications, and firewalls will block the advert. Try temporarily disabling any security applications and firewalls temporarily to test.

The next following steps can help:

  1. Try logging out the Blizzard Application, switch to a different region, click on the X, then switch back to your main region.
  2. Disable the Hardware Acceleration. Go to Settings in the Blizzard Application (Click Blizzard Logo), then under General, scroll all the way down. Under Advanced, uncheck the Use browser hardware acceleration.
  3. Delete the Cache and Tools folder, and reinstall the Blizzard Application.

#13

Did not change a thing, no pop-up or security settings, or switching to another region, nor deleting cache files and the “start button” suddenly appeared today… Just FYI.