Game won't start after patch 29.0.3!

Right after the installation of the last patch on 03/28/2024, when starting the game it stays stuck on an initial screen with the new year button inside the game to update and never enters. The game finally closes itself. Anyone else?? Any advise??

7 Likes

Me too. And the word “global” is all over the place. In the lower left where the time should be, it says “GLOBAL CURRENT TIME”. Hovering over gold, it says “GLOBAL TOOLTIP GOLD HEADER” and “GLOBAL TOOLTIP GOLD DESCRIPTION”. And hovering over the menu button “GLOBAL TOOLTIP MENU HEADER” and “GLOBAL TOOLTIP MENU DESC”. Clicking the menu button gives a menu titled “GLOBAL GAME MENU” with buttons for “GLOBAL OPTIONS” and “GLOBAL QUIT”.

Eventually the game crashes with the text “GLOBAL SPLASH CLOSED SIGN TITLE” and “GLOBAL ERROR NETWORK UTIL TIMEOUT”.

I should note that this is on PC. Just tried my Android phone expecting it would need an update as well. It seemed to work just fine, showing some of the new card updates.

4 Likes

Yeah, that too.

The battlenet client seems messed up too somehow. I tried to “fix and repair” hearthstone but when it reaches 36% my client totally freezes, and then it will also crash my entire PC. Had to restart it multiple times. What’s going on

2 Likes

“Glue Bacon” made me lol

1 Like

LOL… from my last restart due to these problems, my battlenet client suffered some sh1t. Now It doesn’t detect any installed game… Apparently all my games were unistalled

2 Likes

to the end of the world beta game…Fix it…we cant play…we cant even start the game

I was able to fix this by “fix and repairing” am playing now

I’m from Brazil and the same thing happened to me, but I got stressed about this meta, I just want my trunk!! I’m going to play another game while they fix this one: GLOBAL BIG BUG!!

See the image: https://drive.google.com/file/d/1G5Tm5T4Edqt5DRiDU-ixco8_O6hVSnaU/view?usp=sharing

Same here, Im in Europe and my American friends doesnt have this problem. Is it a server issue?? It hasnt been working for hours now. I never had any issues before, the large “refresh button” doesnt react when i press it. After a while it says “Global error network util timeout” whatever that means.

Me too. I’m in a hosed state at the moment as far as I can tell :frowning:

Have the same issue on PC. Some Server just crash other server lock gets to the arrow screen.

All i can suggest is play on another platform android, apple and linux. I know the game works on android as intented.

My issue solved after following this

  1. Click the Cogwheel icon next to the Play or Update button and choose Show in Explorer
  2. Close the Battle.net App
  3. In the Explorer window you just opened, locate and delete the Data folder
  4. Restart the Battle.net App and wait for any updates to complete
1 Like

I had the same problem! You will have to uninstall Hearthstone and then install it again. Kill the problem! And you can play normally again!

Might have helped knowing that. I tried scan and repair and it seemed to really lock up the computer for a while, but I guess it must have finished and I’m in.

1 Like