Game is unplayable.. <1 FPS on start

I’ve been dealing with an issue with Hearthstone for a few months, and the game has been unplayable. As soon as the game starts, the FPS is below 1. Literally unplayable. The caveat: the FPS is perfectly fine if I click away to another app. But as soon as I click back to Hearthstone, the FPS drops back down. it makes no sense. The game obviously can perform well, but not while it is the foreground app.

I’m on Windows 10, using a Geforce 970, and have not had issues until what I assume is a recent game update. I tried rolling back videocard drivers, and reinstalled the drivers entirely. I tried some tricks to get the FPS not to cap, but it does not work. I’ve reinstalled the game on different SSDs, no difference. I have tried on WiFi, and also on ethernet. It is not a network issue. Please , any help is appreciated.

Hey Lollrus,

Sorry to hear about the strange FPS issues when the game is focused. Thanks for providing that info though that definitely helps. I have a few ideas that you can try that might end up helping.

  1. Hit Windows key + R to open the Run window
  2. Type in %localappdata% and hit Enter
  3. Open the Blizzard folder
  4. Delete the Hearthstone folder

This will reset the game settings and local files that the game uses, so it should force the game to redetect everything.

If it’s still happening, lets try rebooting using Selective Startup which should help identify if it’s another process or service that is conflicting with the Hearthstone client somehow.

  1. Press Windows Key+R.
  2. Type msconfig and press Enter.
  3. Select Selective startup and uncheck Load startup items.
  4. Select the Services tab.
  5. Check Hide all Microsoft services.
    Note: Skipping this step may prevent your computer from rebooting correctly.
  6. Click Disable all.
  7. Click Apply then click OK.
  8. Click Restart.

Thank you for the reply. I have attempted both fixes, but neither has resolved the issue. I have also tried forcing the game to play with DirectX 9 as suggested in other threads I’ve come across, but that changed nothing. I have since defaulted all of the settings again.

Hey there Lollrus,

It is strange that Hearthstone is performing so poorly when it’s in focus but seems to be fine when another application is being used. My theory is a program is causing a problem, yet you already tried the steps for a selective restart.

At this point I think a ticket would be best so we can better check over system information files and see if maybe a more specific set of programs needs to be targeted as well as offer other steps that may help. Providing a list of troubleshooting done and/or sharing this forum thread can also help us avoid repeating steps that were tried as well as narrow down the exact cause here.

Thank you, I have submitted a ticket.

The first 1-4 instructions worked for me I was just having this issue.

Thank you!