Can't access to the fourth puzzle in Électra wing


I tried to complete the 4th puzzle of the last challenge in the first wing of Armageboom, but I’m stuck before starting and can’t do anything. (I have a screenshot but it seems we can’t post link here)

Of course, I tried to relaunch the game but nothing worked. Even when i’m on it and tried to click on Echap → Concede or relaunch, I can click on it but nothing happens, I can only quit the game. :frowning:

1 Like

I’m really upset about this issue now. It has been documented for at least a month, and still there has not been even any public acknowledgement or promise of a hotfix date …

EDIT: There’s been an update:

Why would you assume they can promise a fix date for it? I mean I’m also stuck here, but I can understand that sometimes it takes a while to a) find the actual problem, b) come up with a resolution, c) get it tested and pushed to the client. Seeing as how this is older content … the fact that it’s locking up right now is likely indicative of some issue several layers deep they gotta resolve. Not sure why anyone should be upset by this is all.

I’m a little upset because of the fact that an entire patch has come by and gone, and they have yet to even acknowledge this problem publicly for nearly a MONTH now and counting.

Maybe I said the part about “promising a fix date” more out of frustration than anything else at being told to “go away and wait” in polite words, but if they can’t even handle client-side legacy content without completely breaking the game with some of their new patches, then, maybe, just MAYBE, it wouldn’t be the WISEST decision in the world to release any patches that cause such mayhem in legacy content without properly testing them first.

You look at this forum and the plethora of damage that the 21.2 patch did to the base game, the adventures are the tip of the iceberg of why people are so upset.

This points to likelihood that they may have barely tested this patch at all before it being released. How on Earth do they manage to release a patch that breaks single player content? I mean with certain cards being changed I can understand, visual bugs, hey, no sweat, but to break the whole content UI and make an entire campaign unfinishable?

But yeah, lets just stand there and not be upset.

(Especially with the rumoured problems with the Dalaran content that newer players literally had to fork over $$$ to play)

I mean it got so bad at one point that the entire Hearthstone client literally would not even START to play ANY mode whatsoever as this bug progressed(!)

No ranked, no viewing your collection or crafting/disenchanting cards after a patch, no buying new content, no duels, no arena, no NOTHING. We could not even start the game for a while because of an endless resume loop(!)

Why have they allowed such a bug to stay in the game for an entire MONTH without even acknowledging the issue?

I mean, I’ve just got no words …

I understand that the dev team may thoroughly have their hands full with new content, including the upcoming expansion and the new mercenaries mode, but I am EXTREMELY disappointed with their lack of the most BASIC of maintenence in core and legacy content when releasing patches that cause such catastrophic problems in the client …