23.6 Known Issues

Hello everyone,

Please follow this thread for information about known issues with Patch 23.6, which launched earlier today.

  • The Darkmoon Prize, Repeat Customer, has been temporarily disabled in Battlegrounds due to a bug.

  • [6/28, Resolved] A very small number of players incorrectly received a Golden Mercenary Portrait for Yogg-Saron, and/or Yogg-Saron as a Mercenary, after purchasing items that included a Random Legendary Portrait. A small hotfix was deployed to prevent this from happening further, however affected players will not lose the Mercenary or Portrait and will also receive a Random Legendary Portrait shortly after 24.0 goes live. (and Yogg-Saron will be available as a Mercenary soon!)

  • [7/7, Added] The team is aware that the “We DID Start the Fire” Achievement is not progressing.

  • [7/7, Added] Prince Renathal has been banned from the ongoing All-Star Squad Tavern Brawl. Players who already built Prince Renathal decks will need to build new decks in order to queue.

  • [7/15, Resolved] The team is tracking reports that a small number of players are not able to launch the game after the 23.6.2 update, or missing visuals in it. These issues impacted mostly Mac users and/or players with older devices. Some affected players reported that changing their quality settings to “low” was an effective workaround. The 7/15 Client Hotfix should resolve this issue for affected players.

  • [7/14 Added] Nozdormu day is back! But there are reports that the text of the daily quest is not appearing for all players. If you receive a “blank” daily, it’s Nozdormu in disguise! The quest can be completed normally: Play 3 games with Nozdormu the Eternal in your starting deck. Have fun out there, Nozdormu fans.


  • [7/11 Update] Patch 23.6.2 will go live across the various platforms over the next few days. This patch is dedicated to deploying a behind-the-scenes update to the client that may lead to some immediate general performance improvements and will facilitate future improvements. There should be no notable player-facing changes in this patch.


  • [7/14 Update] The team is in the process of releasing a hotfix client update that will fix an issue where a small number of players–mostly Mac users and/or players with older devices–were unable to open the client or were missing visuals after the 7/11 Update. Update to update: following reports that this fix caused issues for a different set of players, this fix has been temporarily rolled back while the issue is investigated.


  • [7/15 Update] The team has addressed the issues with the 7/14 Update listed above and is now re-releasing the update to desktop clients.

We will update this thread throughout the patch period as we have more information to share.


The issue of Mercenaries UI stuck(after using coins to upgrade some skills/gears) had been reported for over a month but still not fixed.

Even not mentioned in 23.2,/23.4/23.6 known issues.


Dopplegangsters are still not re-tuned, forcing very explicit comps for darkshore or ridiculous map re-rolling to dodge greens.


I was playing on Hearthstone and it was in a game with Darkmoon Faire prizes. I was running a Quilboar build and had earned the full amount of Blood Gems you can hold. Before I can have a chance to play them, I have to pick my darkmoon faire prize. I pick the ice block one and the ice block goes away because I can’t hold it in my hand. I’ve had something similar happen with pets before but after I used a blood gem and there was room in my hand, the pets showed up. Unfortunately this time, that wasn’t the case and I never received my darkmoon faire prize.

1 Like

I’ve just experienced a bug with Rogue in Standard.

On turn 1 I have: x2 Blackwater Cutlass, x1 Wicked Stab (Rank 1) and x1 SI:7 Extortion in my hand. I trade a cutlass card and the Extortion goes to 0 mana cost due the ability on cutlass to reduce the cost of a spell by 1 when traded, however, I can’t play it even though it shows up as 0 mana while on 0/1. In turn 2, it still shows 0 mana cost, when played it still takes 1 mana and leaves you with 1/2.

1 Like

Darkmoon prizes are barely readable on mobile.


I just experienced a bug in Battlegrounds where the previously 3 star grease bot but is not 6 star was acquired by AFK on turn 3 because it gave her the option to get it. Which in return won her the game easily.

1 Like

Its not a bug, she got Shifter Zerus as her 3 drop and he in turn morphed into the Grease Bot.


Gear grubber shows an animation for the opponent.

Blademaster okani reveals which choice was picked because it shows if your opponent picked the left or right card.

1 Like

hello everyone, iam experiencing a bug with an achievment in sunken city called I started the fire and despite burning their cards doesnt progress in achievment , thnx a lot!!!

1 Like

Tried to play a friend for the “play with a friend” quest yesterday.

First the game claimed our decks were not eligible for the chosen mode (we both played standard legal decks in standard) and when we finally got a match to start the quest was not completed afterwards.

1 Like

Three things…

  1. It was a tier 4 minion
  2. It was turn 4, not turn 3 when you faced AFKay
  3. Shifter Zerus is a GOD.

I had a question, The new finley doesn’t count as a draw, is it mean to work like this ?

1 Like

That is intended. Card cost and Tradeable cost are two different and independent values.

Bold face keywords have a popup definition when you hover over the card.

In this case Tradeable states, “Drag this into your deck to spend (1) Mana and draw a new card.”

1 Like

Yep, Finley reads “swap your hand” just for this case. And one cannot draw from bottom of deck anyways, only from top (well, unless the card states otherwise, like “moonlight guidance” reads “Draw the original”).

Okani reveals nothing. You can’t say for sure if the pick shown to you is the same your opponent sees. Or you must say like “I always see them picking left followed by minion cancel.”

I can’t make progress on the “We DID start the fire” achievement. I’ve burnt several peoples cards but still no progress.


same here m8, and harold who aswell!!!

Can’t progress Warlock’s “We DID Start the Fire” achievement after latest patch.