22.6 Known Issues

I have phantom achievements… Again!

Also my achievement progress shows 0%

after the patch I am unable to connect to the server. Deleted the app and re downloaded multiple times. Still stuck in the loading screen for hours.

1 Like

Im also as many others i can see stuck on the mercenaris toturial. Where i completed the first task, from Grommash hellscream called: Tutorial 1: What a Boar, wich says completed, but each time i try to claim in the game says ''there was an error claiming your task, please try again later. So i can’t really get further now.

1 Like

So you are aware that the last patch DID NOT fix the duels achievement problem? The issue is with Diablo, Vandar, and Drek Thar. These all say I played 0 times, when I’ve done them a ton.

Today I WAS able to login in Android. I tried several times yesterday so I presume it was a temporary thing, or a server side change, but in any case, it’s solved now.

Still having the login issue

1 Like

The duels queue has been abnormally long I’ve seen a few post about it like it will instant pop a few times then have like 4 to 5 minutes queues then instant pop right after I’ve even had a 30 minute queue happen

1 Like

Did you try rebooting the phone? I remembered that I ran out of battery yesterday night. Maybe that was/is the solution.

I keep seeing a recurring issue that happens almost every time a new set comes out. The collections page keep highlighting cards that are not new to my collection every time I enter the collection page. It got really bad after this last set.

Also with the achievements, it shows that I have some unclaimed achievements, but nothing is highlighted. There is a 2 by the category but when I enter the category there is nothing to claim. I can’t get those numbers to go away.

Sadly it didnt work m8. Reinstalled 3 times, rebooted a couple of times as well. Nothing worked. Just gonna have to wait it seems

1 Like

I’ve opened 3 copies of different legendaries i’ve already owned at the time. that’s really frustrating when you want to collect cards

I am a new player that just started playing on android a couple days ago and when I went into mercenaries and completed the tutorial I couldn’t claim Tutorial 1: what a boar. Please fix this issue I really like this game and I wanna play more mercenaries as soon as possible!


I have been receiving only 3 visitors in mercenaries not including Toki

I just came back to Hearthstone and Im also having the same issue with the tutorial guest for the orc hero in mercs

Same here. Tried restarting my phone several times but did nothing.

Pixel 6 Pro Android 12

UPDATE: Nevermind, I uninstalled and reinstalled it and it’s working now

Everytime you bring new content, you brake the already working functions. Why don’t you hire people more qualified for the job?
I just wasted 30 minutes of my valuable time trying to fix something that didn’t get fixed.
You try to form a mercenaries team and it just bugs the team selection, I can’t form new or modify teams.
Get more qualified people to work on your company, I don’t feel like paying over a broken game.

Gear Grubber let’s the opponent know you have it in hand when it gets discounted. The little flash goes off for both players. I’m quite sure it’s not supposed to work that way.


I also can’t get into duels. The queue keeps adding time to the end of it. Waited for 30 minutes and still can’t get in and I have tried to run it on pc and mobile.

Stuck on Merc 1 mission. I finished but when i want to complete it in the campfire i get an error to try again later…