21.4 Live Known Issues

PC. Clicking Mercenary Mode doesn’t even do anything for me, and when I open the menu and click the quit button, the game crashes.


Guys, i cant even acess the button to play, its frozen to me, and the content i bought on the pre-sale dont even show anywhere, plz help !

On my son’s account, after he upgraded Carriel, the game froze. He cannot change tab on heroes, and he is not allowed to build the second building (the one with the quests)


Btw, PC, talking about the mercenary mode.

I pre-purchased all 3 bundles, yet I still unpacked Sylvanas with no duplicate protection, nor any compensation for the duplicate. Additionally, I opened 64 packs in a row before opening a legendary outside my first-10-packs-guaranteed-legendary. I thought there was a 40 pack pity timer?

1 Like

Can’t open Mercenaries at all.

I updated to the new version, all the other parts of the game are working. Mercenaries is glowing in blue and says “new” but when I click it, nothing happens. I have tried reloading.


hello everyone, I did something quite strange but it worked even if it was to open mercenaries (since it does not let me open it) download an emulator, run it from there and it works for me.
I could wait for it to be fixed but hey it’s a solution after all

I opened my pre-order packs when the tutorial allowed me to, and earned two mercenary portraits in them that I later got through a task.

I took screenshots before and after accepting the reward. There are no signs that I have a duplicate portrait. I didn’t get coins as compensation. Nor did I get a pack.

I simply was punished for opening my packs before finishing the tutorial. I could have gotten another portrait, coins, a mercenary. Instead I got nothing.


“ne item per pack will always be a Mercenary Card and adhere to the rarity guidelines below, and this will always be a Mercenary that you don’t own until you own all Mercenary Cards of that rarity. Once you own all the Mercenary cards of a rarity, you will obtain Mercenary Portraits of that rarity, instead.”

I opened a Legendary portraits and epic portraits before getting all the mercenaries of that rarity. I am missing 1 epic merc and 4 Legendary ones.

Same here keep getting errored out… good thing I waited to by the Merc bundle…

I have same issue, cannot open game mode. Even reinstalled whole game and still same problem!!! :rage: :triumph: :rage:


Jaina Proudmoores 2nd task is bugged. It said “do damage with heating up” (Baron Geddons skill) it was still completed by dealing damage with “ice floes” -skill. But when the task was completed it didn’t give the reward of “frost dust 1” item. The visuals did state it was unlocked but it’s still locked

EDIT: the item became unlocked when i restarted Hearthstone

How about that problem when you cannot open new game mode? Nothing happen when you push the button in main menu?


I also am unable to click the menu option


I have the same issue… all other game modes work fine except mercenaries


Another bug : Reincarnation of Cairne doesn’t proc Reclaimed Souls from Sylvanas, which is not correct, since as Reincarnation tooltip says (The first time that this merc dies…) Cairne dies 1 Time, which should combo with reclaimed souls (Gain attack for each char that died).

Jaina Proudmoor task 2 says deal 85 damage using Heating up but she does not have that skill instead Baron Gedon has the skill named Heating up, yet when he uses it there is progress on the task tracker.

I completed the first bounty, and was in the process of upgrading Tyrande’s powers, when I was disconnected (not my problem, server problem), and now I am just stuck at the Tavern and cannot scroll through my collection or progress the tutorial any further.
I can’t play Mercenaries mode since yesterday night and I’m very upset.

Any news on the “stuck in tutorial” issue? Still unable to build The Merchant Cart (or any other buildings) or open packs. I’m reluctant to continue playing as I currently have 7 mercs at level 23/24 and none of the other unlock able/free ones – I don’t want to leave them behind!


Hi, not sure if this is known but there’s also a bug with Antonidas’s tier 3 task: Flurry of Fire. I think the issue is it requires the third ability to deal damage to progress the quest, but the ability actually only casts fireball as part of its effect, so it doesn’t count.


I preordered the Diablo Pack, yet I still opened the Regular Diablo Portrait when opening my packs. I’m still missing quite a bit of the legendary mercs. Any plans on addressing this? Seems somehow the preorders weren’t protected from the duplication protection that is supposed to be in place.