Game hangs at loading after patch

could you elaborate? I am having this problem. I can’t play the game.

I use window 11. Close the windows Real-time protection. And set language to English for both text and spoken. Tried 2 times. I can play now. (One trick is that click mouse or key board to skip the first splash window. Otherwise it might freeze on those two window. This might help but not sure)

must be something pc related, settings whatever because i have no problems whatsoever.

Having the same problem and was convinced it was my laptop (Lenovo Legion 7) because the game runs perfectly on my desktop (Buypower POS lol). Spent DAYS resetting my system, updating drivers, disabling overlays, deleting dlls, uninstalling and reinstalling Diablo several times, HOURS on phone with Lenovo insisting this laptop is a piece of crap, to end up finding this thread (yes I searched the other day and didn’t find it). It doesn’t aggravate me as much knowing it’s a game problem and not a newer laptop problem! At least I can quit messing with it until they get it fixed :slight_smile:

The strongest evidence so far is that this is somehow related to Microsoft’s DirectStorage implementation. The fix that appears to work most consistently is removing the files dstorage.dll and dstoragecore.dll from the Diablo IV installation directory, then relaunching the game.

To check if you have hardware compatible with DirectStorage:

  • Press Win Key + G to open the XBox Game Bar
  • Click the Settings gear on the right of the top bar.
  • Select the Gaming Features tab on the center menu.
  • Look at the DirectStorage section and check if your GPU, OS, and drive support DirectStorage

Note that if you have multiple drives in your computer, the part to check would be if the drive where Diablo IV is installed supports DirectStorage.

To workaround the issue, you can either move the two .dll files mentioned above out of the Diablo IV directory, or you can migrate your entire Diablo IV install to a different drive that does not support DirectStorage. As far as I know, there is no way to “disable” DirectStorage outside of changing your hardware configuration so that it is no longer supported.

Requirements for DirectStorage aren’t super explicit, but here are the rough points:

  • Windows 10 or 11
  • NVMe SSD
  • DirectX 12 GPU

Really appreciate your tips, it works perfectly for me.
I really hope they will give us a hotfix soon to settle down the disturbance it brought.

The dstorage changes did the trick on my end … but still I do hope they release a official fix for this …

I had this happen a lot in the pvp area. Rest of the game runs fine but PvP is buggy


so looks like DS storage issue after all, hence the “-disableds” command… took them all weekend to figure that out lol… i tried it out and seems to be working fine so far…

The thought had occurred to me that there might be a runtime flag to do that. Sucks that they weren’t able to identify that on Friday at least before some people went the whole weekend without being able to play.

Glad to hear it will be fixed in the next patch.

Adam Fletcher has given us the answer. Here is hoping the have a more permanent solution in the new patch, and a Gauntlet! Let’s get blasting, everyone!

1 Like

When will this problem be solved?

this solution worked for me, looks like they will have the solution with the next patch

My system voice stuttering every few seconds when running d4 with the latest patch.
EVEN once freeze my keyboard and mouse after i left the dungeon. Made me force reboot my PC.

My pc still freezes ranging from 5 mins to 2 hours. Unpredictable and it’s not due to temps/loads

This worked, Thank you!

well work around didnt worrk so d4 you just lost another person when poe or last epoch comes out.Pretty sad most costly game out there and total garbage

1 Like

Did it continue to work? I’m able to get the game working temporarily if i delete the _localprefs.txt file, but eventually it crashes again (when it rewrites the prefs file… which seems to update when changing maps sometimes). I’ll give this technique a try but I have a hard time believing that all of the other folks with fast NVME drives are having these same issues.