Game hangs at loading after patch

I don’t believe so. Both my laptop and my pc are running the game on NVMEs, that does not seem to be the problem. There seems to be an issue, best I can reason, with the UI commands causing a conflict with certain hardware. I literally just tried logging in again, and my cursor color never changed when it locked up. It seems if my cursor changes to the blue that I am using, I am able to get in. Just seems there is an issue loading UI settings from the user profile into certain hardware configurations.

1 Like

In my case sometimes works and sometimes not, and sometimes i get stuck in the loading screen between maps i have to restart and then i’m stuck in the loading screen of the game. combo breaker.

Yeah, this happened to me too. It seems the only viable workaround is to remove the two DirectStorage DLLs as detailed earlier… I really don’t like touching game files so I would not replace them, just move them out of the D4 directory. I did this and it’s working again.

Yep, I have that same exact problem. They really need to go back, look at what they fixed when the game launched, and do that again. It’s a real headache and a real problem.

A workaround I found that seems to be 95% working without touching any .dll files:

  1. Open Battle.net
  2. Open folder where Diablo IV is installed
  3. Double-click the Diablo IV exe file
  4. In Battle.net, click Play to launch D4. At this open the game will hang or may login

The workaround:
5. Close Diablo 4 (Windows will show a popup to close or wait. Just close it).
6. Repeat steps 2 and 3 above
7. Game logs you in

Can’t log in, just hangs on D4 splash screen. Come on Blizzard, fix your game. This is unacceptable!

Scan and Repair files maybe a bad download file

Is there an ETA on when the pc issues will be fixed?

1 Like

I have zero login errors pc

I had to rma my video card this week so won’t be able to play for at least 10 more days. I hope this gets fixed by then. It really is unacceptable 7 months after release.

Unfortunately this stopped working for me.

I went with renaming dstorage.dll to something else and that is working for me so far.

Blizzard needs to address this soon. I’m not sure what I am missing by renaming dstorage.dll to something else.

It is not a bad download file. I have scanned and repaired, downloaded from scratch, updated drivers…it is an issue from the update itself. It seems to be centered around the UI as best as I can tell. But either way, it is an issue from the new patch that is causing the issue. It is definitely something Blizzard SHOULD be working through the weekend to fix, but time will tell if that actually happens. My guess is it will be Monday or Tuesday before we have a solution to this issue. Which is ridiculous, but it is what it is I guess.

Still broken,…

Thanks Microsoft.

On me, there is a coincidence that i started having Black Screens on the day before the patch. I thought that i was already on the new patch when Black Screens started to happen on me. It was so easy to blame the game becoz i dont have such problem before.

It took a lot of observations on resets on every Black Screen occurrence before i was able to identify the culprit.

The thermal paste of my gpu chip on its cooling block was no longer performing due to long exposure of the chip at high temperatures since I’ve been playing my PC on 4k for many months now.

After cleaning all 6 fans of my desktop plus applying a new thermal paste, my game works perfectly fine now.

When the videocard overheats, my system shuts down the card so that it wont get burnt. That was the Blackscreen i saw. After the fix, my gpu temp is 40C cooler with D4 running… no more overheating at 80C+.

I returned the videocard i ordered from Amazon.

Yeah, mine is not a hardware issue. My computer is newer and has good thermal paste. I have no issues with any other game. I also have had no issues straight up until this patch update. It was the patch for me.

I tried logging in again and I got past the Blizzard screen but the character select screen never came up. It hung before it got there.

I just logged in, ran around, use waypoints, talk to NPCs with no issues whatsoever. :person_shrugging:

I’m facing this issue since yesterday, screen hang when loading
adding .bak to dstoragecore.dll fix this issue and didn’t feel any different in game without this dll

Well, was wondering why the game was hanging at launch, guess we’ll have to wait for the devs to issue an emergency patch.

That’s why one should never launch updates at the end of the week. Leaves a bad taste in the player’s mouths.

Did the renaming of the dll file thing not work for you??

Sorry, you’re like my favorite forumite! Are you at least back in, now?

EDIT: and you already mentioned what I said… in the post I responded to.

Don’t mind me!

1 Like

Close the windows Real-time protection. It works for me.