Diablo 4 crashes when it is loading

Adding myself to this list. Facing the same issue with being unable to login whatsoever since the latest patch. The d2storage fix, however, seems to have solved the issue.

Thanks for sharing this! Worked for me, although I had to also remove the dstorage and dstoragecore dlls.

The snafu with using the updated DirectStorage files is that the BNet Updater removes them and replaces with the old 1.02 files whenever it scans for an update. What has been working for me, is to rename the 2 original files, and put the newer build files on my system’s PATH so that the game loads them and are safe from BNet updater.

The updater seems happy now to ignore the 2 renamed files.

1 Like

I’m having the same problem. It will either crash on the red Blizzard logo screen or the black screen right after that.
I’m also have frequent disconnects in game while trying to teleport or leave a cellar or dungeon.
This all started after the latest patch.

Same here. Brutally frustrating.
If you clean cache sometimes it opens the gamer, but teleporting mostly disconnects you. also, the game is very laggy now, and the map is screwed up, among other bugs

We believe we have identified the issue. We will have the fix in the next patch. We have identified an immediate workaround as well.

  1. Click the :gear: icon next to your “Play” Button on the Battle.net Launcher
  2. Click on ‘Game Settings’
  3. Click on the ‘Additional command line arguments’ checkbox
  4. Add ‘-disableds’ to the box that appears.
  5. Launch Game
11 Likes

I’m Having the Same Issue Since New Patch 2/1/2024

1 Like

Works for me, thanks

1 Like

I have been having the game hang on the Blizzard splash screen almost 100% of the time. I was briefly able to log in and play, then it crashed to desktop with no error message, and haven’t been able to get back into the game since.

I have AMD 7900 XTX with the most recent drivers installed.

1 Like

Thanks, Adam, you guys are lifesavers! I played this afternoon by renaming both dstorage files, but I will add this fix in as well for the time being. Thanks for the fix!

2 Likes

This has allowed me into the game and able to play for about 3 hours, so it did help me. Thank you. Today is the first time I was even able to get in the game since Thursday night.

1 Like

still doing same won’t load or if does will freeze when tp tree or other areas

1 Like

whenever i port to any place it game will disconnect. Sometimes even redeeming whisper’s gifts will disconnect me

Have tried -disableds and does not work

Since the patch 1.3.1 was installed, the game could practically no longer be started. Even a reinstallation and “scan and repair” did nothing.
With the help of the “command line argument” ‘-disableds’ in the game settings, the game could be started again.
However, it now happens to me again and again that the PC simply switches off when “teleporting”…

My PC otherwise runs “rock stable” and this behaviour also happens when not overclocked (CPU & GPU).
Memory and power supply have also been checked.

The game ran very stable for me until before the patch - now it’s a disaster

1 Like

like he said plus updated drivers and anything that could be updated you put out new stuff when you should be dealing with stuff that doesn’t work :frowning: insane

1 Like

Running a ryzen 7 3800x and rx6800xt running at 2k resolution. no issue what so ever, until last week. Now Diablo 4 is almost unplayable. please blizzard, fix your game or at least roll back that patch so we can play again.

1 Like

Is this -disableds launch argument something that disables Direct Storage?

Please make sure to enable this launch argument on Steam as well.

People have been complaining about this crash since last June, by the way, and Blizzard report has acknowledged knowing that renaming the dstorage.dll file is a workaround.

I’m sorry to sound negative, but it is absolutely ridiculous to have taken this long to get this workaround. Let alone a full fix for Direct Storage. Blizzard you need to be better.

It doesn’t matter what I try.

Neither renaming, deleting or replacing the files dstorage.dll and dstoragecore.dll with newer versions helps.

Adding the launch argument “-disableds” doesn’t help either. Since patch 1.3.1.49495 the game crashes every few minutes. Before the patch I had no problems with crashes.

When will a hotfix finally come out?

WHEN ?

2 Likes

I think because Microsoft has acquired the company, if folks do not think their job is safe, they are not doing their job.

I have the exact same issue. Game will either freeze on “Blizzard Entertainment” or “Logging in to Servers” screens. The only way I can get it to work is to delete the localprefs.txt file EVERY TIME before I launch the game. WTF.
And then it will crash randomly whenever it feels like. The game was fine before this Lunar Event patch. Come TF on Blizzard. 13700KF + 3090FE, if that matters.