Game hangs at loading after patch

My game patched and after, it just hangs at the Blizzard splash screen. The one in 10 times that I have gotten past that, it hung at login. I have tried restarting the game, restarting my computer, scanning and repairing my game, etc. Nothing is working to allow me to log in. I have limited time to play and yet, here I am unable to log in because your patch broke it.

41 Likes

I have same issue and I did same thing’s as you did.

10 Likes

Ditto - New patch crashes Diablo. Clever move.

Often get to the ‘Logging into Diablo screen’ - sound continues for a bit but then it just crashes.

11 Likes

Same here, i can’t launch the game. It crashes

9 Likes

Confirmed, same issue since patch
I’ve rebooted, checked for updates, and done a scan and repair.

8 Likes

Also getting freezes and crashes since the patch. Prior to patch it was extremely rare that it would ever crash or freeze on me.

EDIT: Restarted game, restarted PC, did scan and repair. Looked for driver updates and found one that was released on the 24th=GeForce game ready driver update to version 551.23 so I updated the driver.

Still freezing at game entry “Diablo” logo. I managed to get in once but crashed as soon as I tried to port to a town.

10 Likes

I managed to launch the game, but it crashed when I tried to go to the Whispering Tree area. I was able to play for 5 minutes! hello Houston, we have a problem!

5 Likes

I am also dealing with the same issue. Gets to the logging into Diablo IV screen and just hangs. Did a reboot, rescan, closed everything, etc. Nothing has allowed me past the login screen.

3 Likes

I feel your pain.

I need my fix.

3 Likes

same… Would be nice to just have an update on the problem at least. it’s clearly an issue for many of us…

2 Likes

worked fine for me but it was extra slow to download and “reclaim disk space”.

1 Like

My game was perfect before patch , after this patch i got frozen more than 6 times in 5 minutes… impossible. i Close and open game and in INTRO start frozen , another frozen was in a Loading screen. TERRIBLE PATCH

2 Likes

Same as everyone else. Game worked perfect before the patch, now I can’t get past the loading screen, it just hangs at either the Blizzard splash screen, or the login in screen.

2 Likes

In my case game works great, and even better, before I had like “upper body view” on characters on default, now I can see them in full glory.

Great patch. Keep going, good work devs!

2 Likes

ended up getting in, but yeah game locked up twice at blizz logo for me too.

Same here stuck on the bilzzard splash screen

Having the same issue here. Rebooted PC and every time it’s crashing on the Blizzard splash screen during the game launch through Battle.net.

Exact issue, game hangs at the logging in screen. I did a scan and repair, but no issues were identified.

Same for me, since patch the game hangs and if i wait long enough it’ll crash on it’s own.
I can then redo it and it’ll go into the game and take a long time,but I expect a crash later to the start screen very soon.

TLDR: Press play 2x, 1st time crash 2nd time long que in.

I was having the same issue, I was able to get past it in windowed mode. Just hit alt+enter after the game starts. Going to try to duplicate it with different display settings now.

1 Like