Game hangs at loading after patch

I confirmed the method is working perfectly for me.

1 Like

I can also confirm that this works. I’ve been able to login and play but kept getting disconnected. I did this and so far about 2 hours of play without lag or disconnects. I am, however, very pessimistic that blizzard will come up with a way to frak this quick fix up before too long.

Blizzard this is bad form from/on you, very bad form that players/users have to come up with fixes for your product… lame

Edit: This game will do in the meantime but frak I’m looking forward to POE2

It worked for a little while. Just had first disconnect.

3 Likes

Renaming dstorage.dll also fixed for me. Cheers for the tip!

1 Like

When are they going to fix it ? More than 32 hours without play because the frozen in new patch.

1 Like

クランのメンバーに聞いたところNVMe SSDを使っている場合でも事象が発生している人とそうじゃ無い人がいます。
超高速なNVMe SSDの場合に発生している傾向にあります。
私の場合は読み込み速度が3500 MB/sの製品を使ってこのバグが発生してます。

回避策としては

  1. 昨夜投稿したように以下の2つのDLLを最新版にする

dstorage.dll (v1.2.2)
dstoragecore.dll (v1.2.2)

  1. SATA接続のSSDあるいはHDDにクライアントを入れる

上記の2種類ぐらいかと。

搭載してるドライブが超高速なNVMe SSDしか無いの場合は、1番目の解決策しかないのですが、公式な方法では無いのでリスクが伴います。

去年の6月6日に起きた同じ現象は割と直ぐに解消されたのに、とんでもなく時間掛かってるのは謎です。

私は今後SATA接続のSSDでのみD4を利用し、NVMeのSSDは使わないことにしました。
体感速度はそんなに変わらないですしね。

------------------------------
When I asked clan members in D4, I found that even if they are using NVMe SSDs, some people are experiencing the problem and some are not.
This tends to happen in the case of ultra-fast NVMe SSDs.
In my case, I am using a product with a loading speed of 3500 MB/s and this bug is occurring.

As a workaround, you can use below:

  1. As I posted last night, update the following two DLLs to the latest version.

dstorage.dll (v1.2.2)
dstoragecore.dll (v1.2.2)

  1. Or Put the D4 client in a SATA connected SSD or HDD.

I think it’s about the above two types.

If the only drive you have is an ultra-fast NVMe SSD, you can only use the first solution, but it is not an official method and there is a risk.

The same phenomenon that occurred on June 6 last year was resolved relatively quickly, but it is a mystery why it has taken so long now.

I’ve decided to use D4 only with SATA SSDs and not NVMe SSDs from now on.
The perceived speed doesn’t change that much.

Are you guys planning on doing anything about the Battle pass items that did NOT unlock for so many of us even though we claimed them. YOUR support ticket what ever states they can’t do anything, and to make a bug discussion post. You ahve a post for it on CONSOLE and PC. here they are, been going on since OCTOBER OF LAST YEAR:::

Premium Battlepass Items Unavailable After Purchasing Premium Battlepass at Level 58 - PC Bug Report - Diablo IV Forums (blizzard.com)

Rewards from premium battle pass are missing - Console Bug Report - Diablo IV Forums (blizzard.com)

It’s been nearly HALF A YEAR and we’ve not even gotten an acknowledgement of the issue from Blizzard.

How is my game still unplayable a day after the patch heading into the weekend and I can’t launch the game because the patch broke it? lol… Guess I’ll be playing Last Epoch this weekend since their team 1/50th the size of D4’s doesn’t bork their game with patch updates.

Barricade had a suggestion that is working for me. Running the game exe as administrator is working. Just open the Diablo IV folder, find the Diablo IV.exe file, right-click > Properties > Compatibility > Run this program as an administrator

Seems less intrusive than messing with dll files so give this a try first and see if it helps.

1 Like

This worked for me too. Wtf…?

1 Like

Properties > Compatibility > Run this program as an administrator also worked for me.

Just to chime in, I replaced the dstorage.dll and dstoragecore.dll files in main game dir with updated ones from 1.22 SDK for DirectStorage, and can confirm that game is working. Reminds me of when the game first launched, and how smooth it was.

You might want to do it the other way around, bring the news from the ‘‘folks’’ here to your team since its often that they find solutions waaay quicker or at least the cause of a problem.
Its been more than a day and some of us would not have been able to even log in if it wasn’t for the community.

2 Likes

this fix worked for me, thank you

Still waiting…

Thanks for the deadly patch blizzard… or microsoft what ever you are now.

still having this issue, are there updates? thanks! :slightly_smiling_face:

Not sure if this has been shared yet, but this appears to be the same issue that happened on launch where people couldn’t get in. If you are running the game on a M.2 PCIe 4 drive transfer it to something different. This should allow the game to load without issues.

I have tried all of the fixes posted here with no luck. Sometimes I will get in and be able to start playing, most times I won’t. I burned three different vault sigils trying to play last night and froze or completely crashed during the run. I have a asus tuf gaming laptop with nvidia 1650 video card and amd ryzen 5. Completely unable to play on it. However, my custom pc with ryzen 9 cpu and 4070 ti has no issues other than a bit of stuttering at times. I don’t know what this patch broke, but it seems to be the same issues that were present at game launch. It just makes it unplayable.

well, i take it back… i think it must have been luck that after i made the forced admin change i got in somehow… tried it this morning and not working again :frowning: what a shame…

From the best I can tell, the issue comes in loading the UI into the game. That is when my game freezes. I use a different cursor color, and as soon as my cursor changes the game locks up. Looked at the Fenris Log, it seems it has something to do with loading UI settings. About the best I have. Still doesn’t make sense why it works on my main pc just fine but crashes my laptop.

Are all NVME’s impacted? I run off an NVME and am not seeing this issue.