Game hangs at loading after patch

Rolled back Nvidia drivers, deleted entire game, reinstalled, checked, ran as admin. Nothing has worked. Game still crashed in Blizzard loading screen, ever since last patch.

Same issue here, keeps crashing.

Same issue. How can this be happening so long after the patch? All other game issues aside, this is unacceptable.

1 Like

same here
:rage: :roll_eyes: :roll_eyes: :roll_eyes: :roll_eyes: :roll_eyes:

Same here, scanned & repaired uninstalled reinstalled rolled back drivers.
Please blizzard fix your game I wanted to enjoy my friday night!

Still trying to be patient but apparently this isn’t getting fixed any time soon… Guess everyone’s in bed. I’d go outside and play in traffic but it’s the middle of the night; wait, maybe that’s the best time…

1 Like

Alt+enter to window mode looks working well for me

It’s still happening to me at this moment. I’m logging in through instead of Steam. Game is stucked at the Blizzard screen.

I tried this and all I see is windows around the Blizzard screen

Same here…game hangs at Blizz…wtf

I found that… The game progress seems to have rolled back.

try removing Dstorage.dll


Yo remove Dstorage.dll works

1 Like

What exactly is the purpose of that .dll besides the obvious name of “storage”?

I was able to play an hour of Helltides by logging to my Xbox. I had this same issue of getting stuck at the Blizzard screen when I was launching the game from Steam. It’s much more common with Steam. With, this is the first time I have seen it since I bought the game from

Edit: I’m able to login to right after I logged out from my Xbox. As soon as I was able to enter the game via, I immediately logged out and relaunch and now it’s stuck at the Blizzard screen again lol.

Did they fix it ?

We have a long time , if i not able to play i bought the game for what ?

Give money Back to PC players if only console can play the game !!!

This the only solution that worked for me. Thank you!

1 Like

Dstorage.dll をRemoveまたはRenameすると言うヒントから、GURU3DでD4のDstorage.dllに問題があるというTopicを見つけました。


つまりD4のDstorage.dll のバージョンが古いせいでバグってるせいみたいです。
D4のフォルダに入っている Dstorage.dll のバージョンは v1.0.2 ですが、
最新版は v1.2.2 なので、わたしはMicrosoftの公式の DirectStorage API Downloads サイトからそれをダウンロードして

dstorage.dll (v1.2.2)
dstoragecore.dll (v1.2.2)


Based on the hint to remove or rename Dstorage.dll, I found a topic that says there is a problem with D4’s Dstorage.dll in GURU3D.

(I’m sorry if this forum doesn’t allow you to post URLs directly, so the explanations are only in words, so I’m sorry if it’s hard to understand.)

In other words, it seems that the bug is caused by the old version of Dstorage.dll in D4.
The version of Dstorage.dll in the D4 folder is v1.0.2, but
The latest version is v1.2.2, so I downloaded it from Microsoft’s official DirectStorage API Downloads site.

dstorage.dll (v1.2.2)
dstoragecore.dll (v1.2.2)

After replacing the two above, I was able to play the game without any problems.
However, this method is not official, so try it at your own risk.


deleting dstorage.dll worked for me! Funny how the community found a fix way before an official one! GG


it is related to the speed of the nvme ssd drives as per my testing. copying to a non nvme ssd works like a charm. bump it for people to know the solution.

That’s because they don’t play their own game…

1 Like

Same Problem here. Graficcard is up to date. Game repaired… stil hang on the loading screen. Cant play the game.

Thats one of the worst patches ever…