Game hangs at loading after patch

Also worked for me. Thanks for the hint.

Very nice, Blizzard. Your incompetence is astounding !
Keep it up, you’re doing just fine !!

1 Like

How about instead of thanking us for our patience you just get your sh#% fixed.

2 Likes

dstorage.dll is probably the front end for DirectStorage. DirectStorage is a high speed file read API intended for modern games. It allows file I/O to be performed with significantly lower latency and CPU overhead.

I do not recommend people do this. As Diablo IV has some form of anti-cheat built in, this sort of change will be prone to running afoul of it as game program files would not match what is expected.

Additionally the reason the DLLs are deployed by the game and not as part of the OS is because the API might be subject to breaking changes. As a result a newer version of the DLL files might not be suitable to replace older ones.

Like wise deleting the dll might not be a good idea from this perspective as then an expected piece of program code is missing.

2 Likes

just patched this morning, trying to start my day with Diablo and Coffee… looks like it’s just gonna be coffee today.

2 Likes

去年の6月6日に起きたNVMeのSSDの問題がまた発生しましたね。
つまり開発陣はデグレードを引き起こしたと思います。
開発資材を正しく最新化できてないと思いましたね。
Blizzard社はいったいどんな管理をしているのか首をかしげます。

------------------------------

The NVMe SSD problem that occurred on June 6th last year has occurred again.
In other words, I think the development team caused the degradation.
I thought that the development materials were not properly updated.
I wonder what kind of management Blizzard is doing.

I have the issue on two different laptops. 1 Windows 10 and 1 Windows 11.
All after the patch.

Holy Crap, this issue is still happening today?! UNREAL

And you rly dont need an PTR??
There are so many bug… and you are not in the position to test it the way you need to.
Set an PTR…get the feedback… fix the bugs… Release it on live and all happy…

1 Like

I am also unable to get past login since the patch. I’ve tried the following:

  • Reboot
  • Scan and repair game files
  • Check for driver updates
  • Uninstall and reinstall
  • Run sfc /scannow
  • Uninstall, delete local D4 folders, reboot, then reinstall again

None of that has changed the behavior of the game. It will start, maybe get through a splash screen or two, then freeze (though audio sometimes continues for a bit) and Windows will come up with the dialog that says the game is unresponsive. At that point it will send the error to Microsoft and then close the program.

1 Like

Happen many times to me, too!

It’s the NVME issue. Once i moved the game to an SSD it ran no issues.

Same issue. Please help.

This is very very insightful with hopefully many helps to fix this issues we having with game.

24 hours later no fix, dude, have they heard of a rollback or smt.

Trading disabled for 1 week now, omegalul

Can’t pass the splash screen here neither…
Seriously…

As others said this is the nvme bug/issue that many had at launch. if you have a ssd mmove the game there and it will run. If you don’t have a slow drive to put it on i rememeber there was another workaround where you run another app to stress your nvme(sorry don’t remember the name) while logging in

Some good dudes gave the solution here : SOLUTION to at least get in

You need to rename your dstorage.dll (in Diablo 4 folder) then it works !

why should “updating” the dll do the trick? DirectStorage isnt even activated in the game’s exe, nor there are any flags to activate this feature…

Seems like HokusPokus like “alt+enter” until real fix.

see, if the Game would/could use DStorage, the Game wont load without loading them…

I went to bed and after 8h, I’m still unable to login. I am stuck at the Blizzard screen