Diablo 4 crashes when it is loading

These did not help, the game still crashing and also Hardware acceleration GPU scheduling is on by default in windows 11

2 Likes

I have same problem, could not login. failed every login after patch 1.3.1 of D4

1 Like

same problem after update diablo 4 its grrrr

1 Like

Hey BLUE!!! any answer about that issue - we can’t play game, everytime when try to login game window is freezing!!!

2 Likes

Having the same issue since the most recent patch. Uninstalled and reinstalled and it still does it. Very frustrating…

1 Like

Same problem here but thanks to this I was able to log in

13 Likes

Same issue, doing this worked for me

it’s works for me :slight_smile:

This did NOT work for me. The first time I tried after removing the dstorage.dll file froze in between the Blizzard logo and the Diablo IV logo, then the second time froze, as per normal apparently now, on Logging into Diablo IV. It did this back in June when the game launched. I don’t know what was changed, but something has to be fixed on Blizzard’s end. This is ridiculous at this point.

2 Likes

Try this, actually worked like a charm for me…

1. Go to the Diablo 4 directory.
2. Make a copy of the file dstorage.dll and put it in a temporary folder for safe keeping.
3. Rename the file “dstorage.dll” to “dstorage.dll.bak”

Of course stop the launcher beforehand, restart and so on.

4 Likes

Thank you for sharing! It worked for me. I can finally pass Blizz logo.

1 Like

This solution also work for me.
But I remeber that similar problem exist when diablo starts. Same of SSD disk and D IV dont work properly.

I can confirm that this fixed the issue for me

Fix worked for me. dstorage.dll removed and it loads fine.

This worked for me too. Thanks!

Fix not working for me. :frowning:

Also running into the same crashing issues trying to login and whenever I am in, anytime I am in the loading screen I crash

I got the same issue after patch.
Seems like the same issue when D4 first launch?

worked for me perfectly thankyou. I was starting to pull my hair out a bit.

Same issue since this morning. Haven’t played in a few days but never had an issue prior. the dstorage.dll suggested workaround gets me to the character screen. Hoping to be able to play.
Blizzard folks need to wake up and fix this already.