Slow load times - Inventory

It seems like that somebody broke the file caching mechanism. It used to work fine before season 21 release. It should not try to read data from file system for frequently used assets. Even for advanced logic, it can try to predict the future usage of assets and load them in memory in order to minimize disk access.

2 Likes

I have the same issue as well but I’m using a hackintosh.
Specs:
Intel Core i5 8th gen
GPU: Radeon RX590 8gb
16gb ram Hyper X
OS: Mojave 10.14.6
NVME 2 Western Digial APFS

1 Like

I have the same issue, going to test the proposed workaround to set texture quality to high and change back, will post back if it works for me. Only been playing multiplayer the last couple of days. When left solo in the party it seems to heal itself and get better but that is just how I experience the issue.

Spec:
macOS Big Sur
Version 11.0.1
MacBook Pro (16-inch, 2019)

Processor: 2,3 Ghz 8-Core Intel Core i9
Memory: 16GB 2667 Mhz DDR4
Graphics:

  • AMD Radeon Pro 5500M 4 GB
  • Intel UHD Graphics 630 1536 MB
1 Like

So, didn’t experience this issue at all during solo play. Will check back later when I’ve tested this during multiplayer.

1 Like

Does it still work with texture on high? I noticed when I change settings to something different it will work that session but then next session will not work.

1 Like

I uninstalled Big Sur and went back to Catalina. The issues are still there. Game used to play fine on Catalina for months but everyone, including myself, assumed it was a Big Sur issue. It clearly isn’t as the issues still exist on Catalina. Something must have been triggered by the new patch/new season update.

3 Likes

Same issue here in act 1 and 3/4 town area. It’s not an internet issue, as the game itself downloaded within 8 minutes less than 45 minutes prior to seeing the issue.

On macbook pro 15in 2018, high sierra

OS: 64bit Mac OS X 10.13.6 17G14042
Kernel: x86_64 Darwin 17.7.0
CPU: Intel Core i7-8750H @ 2.20GHz
GPU: Intel UHD Graphics 630 / Radeon Pro 555X
RAM: 8874MiB / 16384MiB

SSD: 80gb free / 500gb

3 Likes

Same problem here, started recently and is progressively getting worse if anything, making the game pretty much unplayable. Setting everything to high seemed to fix it for a few minutes but the problem quickly came back.
I’m on a MacBook Pro (Retina, 15-inch, Mid 2014)

OS: High Sierra, 10.13.6 (17G65)
CPU: 2.5 GHz Intel Core i7
GPU: NVIDIA GeForce GT 750M 2048 MB Intel Iris Pro 1536 MB
RAM: 16 GB 1600 MHz DDR3
SSD HDD
File system: APFS

3 Likes

Same problem here, started recently and is progressively getting worse if anything, making the game pretty much unplayable.

I’m on a MacBook Pro (Retina, 15-inch, Mid 2013)

OS: Big Sur, 11.0.1
CPU: 2.3 GHz Intel Core i7
GPU: NVIDIA GeForce GT 750M 2G
RAM: 16 GB 1600 MHz DDR3
SSD
File system: APFS

1 Like

You! You’re my hero. Thanks for the insight.

1 Like

Same issue here. In solo is playable but in multiplayer inventory checks can take 10-20 secs to show the items. S21 was the same for me and I havent change my OSX, still in Mojave since release so i think its not related to Big sur at all.

|Model Name: 15,1|iMac (5k, late-2014)| i5 3.5 | 16mb ram|
|MacOS Version |macOS High Sierra (10.14.6)|
|Graphics Chipset Model: |Radeon Pro r9 M290x|
|File System: |APFS|

Please fix that issue!!!

1 Like

Did that work for you? Didn’t work for me.

Well that pretty much points to the 2.6.10 patch, because 2.6.9 was OK. Remember we had that odd not able to participate in the PTR for all Mac users, would say what ever workaround blizzard used, it not a complete fix. Running 11.1 beta

1 Like

I agree, Blizzard. please stop trying to imply the issue is on our side. We have seen a myriad of OSes having the issue from Big Sur down to Mojave. Please acknowledge the issue and work on a fix. I know that diablo is not a much a priority anymore but you you have a service level to maintain and this is affecting your user satisfaction and gameplay. I tried the suggestions of reinstalling it work just briefly and the inventory lag is back. Please address acknowledge and address the issue.

9 Likes

This is garbage and after testing a number of configurations it seems related to the season patch. Basically the only work around is try and stay in Caldeum. For whatever reason the issue isn’t as bad from that map.

3 Likes

Seems like the only place you can stay is Act 2 without too many issues. Still no response from Customer Support???

2 Likes

Not sure what is taking Blizzard so long to address this issue… The issue is HORRIBLE to say the polite way…

Tried uninstalling Battle.Net client, Diablo 3… No help at all, still the same issue. 10-60+ seconds for stash, vendors, etc to load. Delays in drops to the point I leave not wanting to wait 10-15 seconds for deaths breath to show. You can see it drop, but it doesn’t appear on screen to pick up…

This happens consistently on two different Mac’s. One running Catalina, the other running Big Sur… Both have more than enough horse power…

Catalina Mac
IMac: Retina 4k 21.5" 2017
Processor: 3Ghz Quad Intel i5
Memory: 32 Gig
Graphics: Radeon Pro 555 2 Gig

Big Sur Mac
MacBook Pro 16 inch 2019
Processor 2.6 Ghzm 6-Core i7
Memory: 16 Gig
Graphics: AMD Radeon Pro 5300M 4 Gig

The iMac has even longer wait times for drops.

Blizzard really needs to find a solution to this problem. It isn’t helping my faith in what they are working on for D4 either…

3 Likes

They already got our money on this game years ago and it seems pretty clear they don’t really care at this point. Additionally, we are Mac users which probably represent a small percentage of their players, so that probably means they care even less.

2 Likes

Agreed, although they are the reason money stopped flowing in on this game. They decided after the Necro to not release any new expansions to purchase or any additional game play we are willing to pay for… Just seasons and other items they are unable to charge for… Regardless it was their choice to stop the flow, not ours.

Same here. Sitting on 1000 mb/s internet connection so clearly not a problem on my end.
Can we please get a word from support on this, its really geting on my nerves

1 Like