In-Game Item Images Won't Load for at least 10 seconds

I’m not sure if this is happening with other players as well, but this is really frustrating. Every time I open my inventory, the item images just won’t load or show.

Have you tried increasing your graphic settings as suggested in:

If you’re on a Mac, there is a topic running here:

Yes already did, same issue.

What I did notice is that this is not happening when I’m in Act 2 town.

1 Like

True, same situation on my MBP 15

When I’m playing happened this the stash chests, inventories are empty for 10-15 seconds and more frequently when playing in public session. Already tried clearing the cache but nothing.

The workaround to this was documented in the first thread Boubou linked back in July 2020, i.e. change your texture quality (from high to low and back again, or vice versa).

Another example…

I see Blizzard don’t have any real interest to work the BUG have D3, I say is a Bug because I can see almost well my items in Caldeum the problem is I can’t stay all game in caldeum specially im playing in public… I downgrade my video performance and I no have idea what to do, think is better not buy any Blizzard product any more. Since they get compromise to admit what is a problem in the Diablo 3 script game what run only in Apple and fix it.
I let my chat support link for get laugh or cry…