Icons taking too long to load

Hello! I’m having this annoying problem, the icons are taking way too long to load, even a minute which is very annoying

Looks empty but the Stash and inventory have both items, even the             buffs icons are missing.

Its not my internet, which is fine, I don’t understand why are they taking so long to show, even when they do, if I close the inventory and open it again they are gone again, the icons should be on the game files so they can’t be being downloaded every time I open something…


Increase your graphics settings under options- will fix it.

Confirmed fix.

During S20, I set my Texture Quality to “Low”, thinking this would improve performance a bit.

This causes your inventory/equipment/bank/vendors to load slowly during S21, even on a fast connection.


Set Options > Video > Texture Quality > “High”

1 Like

issue still there for me. I only notice it doesn’t happen on Act 2 town.

1 Like

I experience the same as this. The icons in my inventory, the tabs on the blacksmith, jeweller & mistic, the items I’m wearing and the map background… all take anything from 30 seconds to 1 minute to load. If I want to see what I’m wearing before its loaded, I can click the item and the one item loads instantly.

This is definitely not a bandwidth thing. This only happens in act 3 and 4. I have to go to act 1, 2, or 5 to work with my inventory properly, without waiting for ages. Additionally, if I open a horodaric cache in act 3 or 4, only 1 item drops, and 30 seconds+ later the remaining items drop.

I have tried deleting my Game cache, and my texture is already on high and Low FX is disabled. This is most certainly a bug or a corruption of sorts. I’m running MacOS Catalina on a 2015 iMac.

It’s very frustrating!

1 Like

I just ran into this bug as well. Everything loads slow, at Kadala, at the Blacksmith, Jeweler, Mystic. Including my Stash and Inventory.

The only place where it seems to work is in Act 2. I’ve switched characters and they aren’t affected. Just the new season character! I’m at a loss. Please help.

1 Like

I just want to give you guys an update. I switched to the 64-bit client, and the problem went away, at least for now.

1 Like

I have the same issue. It began when the last season ended.

Mine has always been set to high in every season. This issue only began when last season ended. It continues with the new season. My setting is high.

Change from 32 to 64bit. Worked for me.


changing diablo III to 64bits fix the issue for me too.

You can change it in the battle net client before opening the game.
Path: Settings/Game Settings/Diablo III/
uncheck the option “Launch 32-bits client (instead of 64-bits)”