Bad Performance since Update on Big Sur

Hey friends.
Yesterday i updated my iMac to Big Sur. Since the Update, the Performance of the Game ist realy bad. Low Performance, bad FPS: Is there any Idea what I should do?
The Game and Big Sur was a complete new Installation. No Update.
My System:

Modellname: iMac
Modell-Identifizierung: iMac (Retina 5K, 27 Zoll, Ende 2015)
Prozessortyp: Quad-Core Intel Core i5
Prozessorgeschwindigkeit: 3,2 GHz
Anzahl der Prozessoren: 1
Gesamtanzahl der Kerne: 4
L2-Cache (pro Kern): 256 KB
L3-Cache: 6 MB
Speicher: 24 GB
Grafik: AMD Radeon R9 M390 2 GB
16 Likes

Having the same issue. Wiped machine, installed macOS Big Sur, and the game is close to unplayable. It used to play fairly decently under Catalina.

4 Likes

I have the same issue, very bad FPS and super slow performance

4 Likes

you should be looking in MAC forums. It’s not a wise thing to update to the latest Mac OS ever if you want things to keep working the way you are used to.

And there’s multiple issues with BigSur and tons of apps

1 Like

Same here, horrible FPS after update. Please fix it soon as the season 22 starting in just 3 days.

1 Like

I been playing D3 since beta on my 2017 iMac. I never had an issue. I will know how it will run on my M1 Mac mini tomorrow.

1 Like

Just upgraded to Big Sur on my 2017 iMac, expecting it would be no issue as usual… but it was a very bad idea, D3 is now un-playable, it is so slow and lagging… horrible, won’t be able to play Season 22 start… crap :frowning:
Please Blizzard, help !!!

6 Likes

Same issue. Pretty new and powerful (2019) MacBook Pro. It’s hit and miss. Sometimes the play is like before, but usually very slow and laggy. Sad. Hope there is a fix soon!

Interesting. My performance after the Big Sur upgrade on a 2018 15" MBP is exactly the opposite. My framerate increased significantly.

2 Likes

Having same very slow lag and FPS making it unplayable after Big Sur upgrade on a 2014 Mac Mini. Worked fine under Catalina. Every other app seems OK but D3

1 Like

Same Problem here: Mac Mini
Used to work with catalina, now with Big Sur even with lowest graphics settings almost not playable. It seems like the graphics settings have almost no impact at all

2 Likes

I’m having the same problem here guys since updating to OS Big Sur been having lagg spikes FPS drops everything is so slow almost unplayable gets me killed as well on GRs especially when playing my monk.

1 Like

Hello again. I saw an update in the background while working. Now it seems to play better. That’s good news. And the large cursor has a colored outline, making it easier to see among the candy-colored carnage of play.

I am very curious how it runs on a new M1 Mac.

I also hope that Blizzard will provide an update as a M1 native app.

Hi,
Same issue here. I did the upgrade to “Big Sur” and now D3 is impossible to play.

  • Macbook Pro 2013 Quad core i7 2.3 Ghz.
  • 16 GB RAM
  • NVIDIA GeForce GT 750M (2 Gb).

Horribly SLOW. Unplayable.

From very fluid and perfect to play D3 with Catalina, it became impossible to play since Big Sur upgrade.

Is there a fix for that ?
Is Blizzard working on this issue ?

Thanks a lot for your help,

Thierry

3 Likes

I’d like to hear the solution to this. We just bought a new iMac (2020) after running Diablo III on a 2009 iMac for the past 8 years. I expected we could ramp up all the settings, but am really surprised to see much more than 40 FPS makes the game unplayable. Also, there is an issue with inventory taking a long time to load; never had that problem before.

I’m wondering as well if Blizzard is aware of these issues and is working on a patch for them?

4 Likes

UPDATE: Still having same problems. Help, Blizzard!

3 Likes

I had the same issues with Big Sur. Just played around with the graphics settings a bit (in Diablo) and it worked after a while (in terms of being playable now). Lower the resolution, that made the biggest difference I think.

Same issue: uploaded Big Sur and now the game is really bad. Lagging a lot. Please, do something!

3 Likes

I am having the same problem noted above. Please help.

2 Likes