This account does not own the game

I purchased COD MW last night on my PC, downloaded it, loaded the blizzard battle.net client and when I start COD MW it states that this account does not own the game. I am using the same account that I purchased the game from.
Any help on why this is occurring? I have paid receipts, confirmation numbers, used the blizzard battle.net website, not sure what is wrong.

3 Likes

I have a similar issue. I preordered the operator edition. Played in the early beta or whatever. On the battle.net website it says i have a game account but on the battle.net launcher it says i don’t own the bloody game and it wants me to purchase it again?!

4 Likes

Having the same issue as well, so not impressed that not one support person has commented on any of my posts to help so frustrating

1 Like

_ Have the exact same problem. Pre-paid for game. Downloaded it. Cant play because server says I dont own it._Also have proof of purchase. Error code BLZBNTBGS00000033

2 Likes

Same problem please help!

Have the same problem

And Blizard didnt show me instal the game

Hi there friends,

If you still have this issue and are on the right account, please try resetting the blizzard app.

Perform Steps 1-5 here after that do not reinstall yet but follow these additional steps:

  1. Open file explorer/file manager
  2. Type the following into the address bar (not the search bar): %APPDATA%
  3. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
  4. Repeat steps 2 and 3 with %LOCALAPPDATA% and %TEMP%
  5. Empty the recycle bin.

Checking on each of you now.

I do hope to see you in game soon! I know these problems are never great to deal with.

/Nathardrick

1 Like

I have a similar issue and its very annoying. Every time I go to purchase the game, it either A. just takes me back to the main shop menu, or B. Tells me the “purchase could not be completed”. The annoying thing is I was able to download the game, all 100+ GB of it, and I can run it via the Battle net client, and yet it just says I do not own the game on this account, and gives me the same Error Code. I want to know why I cant buy the game? I tried adding funds but the same things happen, and I tried to do it via their web page and their client, still wouldnt work. PLZ HELP!

I did purchase the game, but I purchased it though Games Planet when I claimed my purchase it brought me to battle/ blizzard to download. It took over 24 hours to download so I do know it downloaded as others I see in the forum complaining about download speeds. Is there a way to speak with a live tech support agent? thank you for finally responding

OTGGoddess,

I see that you’ve already gotten in touch with our support team. Sorry for any confusion. This exact account DOES have Modern Warfare claimed successfully, at least as of now. We just didn’t see the order since you ordered it through a third party.

I checked some other things out and it looks like you are probably logging into the wrong email address on the Battle.net Desktop Application. Double check that you are using the correct email to log into the application and things should be fine.

I would wager that anybody else who logs into our website and sees the license available under game accounts at this link is having the same problem. If you log into the website and see the games at that link, make sure you use the same email to log in to the Battle.net Desktop Application.

If you do NOT see the game you are trying to download there, please contact customer support instead for help finding the correct account.

I actually contacted Games Planet and got a refund because after over 24 hours of trying to fix this issue and contacting several companies about the problem it just seemed like an easier solution. I have repurchased the game through your website and hope everything works out well with the game and download.

Fair enough. Well, if you end up having any other issues with the install just let us know!

My account does not show that I made the purchase of COD MW. My order no is 525770347. The purchase was made on Sept 23 2019 via PayPal. My Battle Net Tag is : Judgedredd#11310

i have reported this problem several times. i reset the app and everything. I was able to play the beta as well and now all of a sudden i cant play at all. This is the right account because it shows that i have even played it before. What is even weirder is it doesnt show in my transaction history. Plz help i am becoming frustrated by the minute.

Hey Judgedredd,

I checked and this order was placed under a different account. We can’t provide information regarding this situation over the forum so I would recommend creating a ticket and putting that order number in the text so we can get this sorted out.

1 Like

Hey ItsDraggin,

I took a look and don’t see any COD:MW orders or keys attached to your account. It looks like you only had accessed the beta previously from this account. If you purchased it, then it’s likely it was purchased on a different account. I would also suggest putting in a ticket so this can be investigated.

Upon redeeming my NVIDIA code and having its be successful through the Geforce app each time i attempt to open the game through battle.net i get the same error code saying this account does not own the game.

I think that my account and my son’ s account got mixed up some how. I see games in my account that I know he has purchased. It also had his player name in my profile . If I’m right, he most likly is locked out of his account.How can we fix the mix up ?

i also did the same… went to blizzard.com, purchased the game. sent me to download battle.net. still have the same issue after uninstalling and reinstalling battle.net