Stuck on "Updating the battle net update agent"

try running battle net as administrator

same thing is happening to me.

Just quit trying, and Blizzard should quit goofing off too

1 Like

I have the same problem for 4 days…

same issue, cant update any games or even reinstall battle.net the installer is a joke will not be renewing my WoW subscription after the 5 months purchased expires since I cant even access the game I paid for

The code dancers at Blizz are getting ready to launch the pre-patch to DF follow closely by DF it’s self so this is about right given the time line for whats coming

well its been a few days… tried all the suggestions above and none worked. i can’t even reinstall bnet on windows now.

Bonjour,
J’ai le regret de vous annoncer que après une absence de 1an sur battle.net j’ai voulue me reconnecter et installer la mise a jour de Overwatch 2 mais il fallait que je le réinstalle donc en le appuyant sur installer le calcul des donnée rester en charges pendant des heures alors je me suis dit que mon battle net était tout simplement pas mis a jour et du coup je l’ai désinstaller et pour le réinstaller en ayant télécharger le dossier battle.net setup quand je le lance la barre bleue charge tout les dossiers s’installe mais la barre reste bloquer au maximum et il est marqués: Mise a jour de battle.net je le laissée pendant des heures mais battle net ne veux pas s’installer et par la même occasion je ne peux jouer a Overwatch que j’ai payée avant qu’il soit gratuit je ne sais pas quoi faire j’ai essayé énormément de chose sur vos assistance mais rien ne fonctionne aider moi.

they are legendary at not fixing any issues tha exists for months (since march 2022). Still trying to this day to install the bnet app with every step they say but not even a chance of installing it.

1 Like

Its having a conflict on the previous installation of battle.net, if the battle.net still exist on the programs list but you can’t uninstall it due to certain error.

This one might work for you
coz it does for me:

Install Iobit uninstaller to totally remove residual files. (Don’t worry its a free file , go to filehippo and search for the app)
Select the battle.net exe file to uninstall
Wait to delete all residual files.
then after that, you’re good to go

you may now re-install the battle.net setup!

Thank me later :wink:

1 Like

I had the same issue at the beginning of 2021 and I still cant get it to download.

i love you, this helped soo much

Anyone manage to solve this? Had trouble playing MW2. Keeps crashing, Reinstalled Battle net. played for 1 hour. crashed. now i cant even reinstall battle net. Did everything they recomended besides uninstalling windows. seriously all this within 1 day of buying the bloody game.

The solution that worked for me is using internet hotspot (usb theering 4g from my phone instead of wifi) .

share 4g from your phone (Usb theering) and launch the installer using it . it worked for me

I also have this issue now. Initially stuck on “initializing”, then uninstalled Battle.net, tried to reinstall and since then either stuck on “Updating battle.net” or at 0% when trying to install… Tried all steps I found anywhere, no solution.

1 Like

me too, i cant install battle.net always stuck at 0%

Same here, fresh install windows, i want to install battle.net stuck at 0%
in the logs file i found this :

ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\downloader\source\downloader\standarddownloaderimpl.cpp, line 977): failing download ID 1: fetch limit exceeded
E 2022-11-16 21:20:27.767536 [Main] {28a8} ContainerlessUpdate - {28a8} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_tact\source\user\tools\containerlessupdate.cpp, line 1181): failed to download data for ‘tpr/bnt001/config/31/4b/314bb651121eda095a3154f33ce60be0’
E 2022-11-16 21:20:27.767581 [Main] {28a8} ContainerlessUpdate - {28a8} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_tact\source\user\tools\containerlessupdate.cpp, line 1174): Retry request: ‘/tpr/bnt001/config/31/4b/314bb651121eda095a3154f33ce60be0’ (0, 18446744073709551615)
W 2022-11-16 21:20:29.782803 [Main] {2598} Downloader - {2598} WRN (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 2080): HTTP: connection timeout for ‘137.221.64.8:80’
E 2022-11-16 21:20:29.782905 [Main] {2598} Downloader - {2598} ERR (d:\buildserver\bna-3\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\fetcher\source\fetcher\httpfetcherimpl.cpp, line 392): HTTP: connection failed for host 137.221.64.8:80: NET_CANCELED

Thank You blizzard for your support :D, which didn’t happen :(. Same issue on the day of pre patch before Dragonflight, very encouraging to playing…

1 Like

I solved my problems by using a VPN server New Zealand

2 Likes