Stuck on "Updating the battle net update agent"

This process (manually deleting folders) worked for me. Thanks

I was able to download the desktop app today with no issues after just logging onto the website and clicking the download button.

I got past the updating battle net agent but now I am stuck on the battle.net installation where it gets to about 89 percent before it stops downloading.

2 Likes

Fixed the issue by resetting the WMI repository here Resetting the WMI Repository - Blizzard Support

I’ve had the same issue the last 2 updates… First time I re-installed Bnet and the game… Now after reading on forum’s etc I saw that alot of people had to wait aprox 1 hour for it to actully start after getting stuck on " 0% Initializing ". I tried that and after about 20min the download started but at 200 KB/s. I have a 500/500 internet connection and my computer is connected with cable. Only person in the house using internet atm.

Hopefully Blizzard will fix this issue. Don’t have any faith that they will, but let’s hope for it.

Have had issue also since they changed agent.exe about 5 days ago on the backend. Have tried Linux route but am going to see if I will be having issues updating in Windows next. The .dll is missing though, have seen that error, the update starts but stops fetching. In Windows I used to delete the battle.net folder, might try that and see if it works. Usually deleting battle.net folder or reinstalling Windows fresh would fix past issues, and am planning to try that later today.

What are you guys doing to fix this, its causing everyone problems and its not suppose to be on our side. You guys have been really botching this game up lately. I was in game all afternoon and now once I restarted my computer so I could try and get this download to work, I can no longer open the game back up. Thank you!!! RIP

Fix that worked for me, Fresh installed Win10 enterprise (lite edition 22h2 iso) and installed battle.net and WoW completely from scratch (am patched, retail confirmed working). I also had success with fresh install battle.net in win10 pro WM prior. Think it might be the battle.net folders or something else with agent. Have not tested back on Linux side yet (wine compatibility broke a few days ago). But a fresh install had me able to play and patch to latest again in Windows 10. A lot of people in the Steam Deck forums have had success installing by copying over Windows files, deleting the battle.net folders might also help. Best wishes!

I resolve the issue after 2 days.
I forgot to delete the battlenet folder and the blizzard folder inside the root
C:ProgramData\Battle.net
after i delete this folder everithing works.

I got the Bnet App re-installed, but I am stuck on “Looking for another Update” when trying to play Starcraft Remastered. It does not find or install any Updates and the progress bar stays on Zero. UPDATE: REBOOTED ROUTER - Updates finishing

having same issues as everyone else id like to play sometime today

Been stuck on this issue since yesterday. Did the whole clear current install and do fresh install from scratch. Did all but reinstall windows and it’s still stuck on “Waiting on another update”. And if tech says again that this is network or router issue, then he is just reading from silly KT wiki and has no clue.

My problem of being stuck on updates happened after an outage of my cable after a thunderstorm. I was glad when service was restored. But I was getting stuck on Battlenet Updates. Service was restored, but my Router/Modem needed to be rebooted to get all the tcp/udp connections re-established. I unplugged for 10 sec and let it reboot. Updates are working fine now.

I too am having a problem with my agent unable to recognize my signature and am unable to uninstall anything and i have done my best to follow every solution i am giving but still nothing :frowning: anyone get a solution?

I had the same problem.
I delete all the blizzard folder in the pc.
After i delete the hidden folder: C:ProgramData\Battle.net
If you cant find this folder probably you need to enable your pc to show hidden file.
After that you need to install the battle net launcher.

I did try to do full new install and I can’t get game to install. After I click Install button it hangs there for over an hour and does not start any download. I tried other games in btnet and they all have same issue. I removed all games and did fresh install btnet with only DI added, but still can’t install it now anymore.

I’m having the same issue, b-net will not update. I uninstalled, deleted folders and got it to install finally only to have it stall trying to get the update. Its not a network issue because me and my son are on the same modem and his works perfectly fine and downloaded the warzone update fine. Blizzard needs to fix this, i have the latest drivers and the latest windows update.

do the hard “reset”, byt that I mean: delete battle.net folder in the program files, in your user’s appdata and on program data (this one is hiden in C:, maybe blizzard folder too ), and reinstall the app.
The “pros” in blizzard have made some mistake and many users got something “broken”/corrupted in one of those folders. (save a copy just in case but).

Still having the issue, Blizzards copy/paste response should be getting flagged for spam at this point

Wasn’t on for 2 weeks now having this same issue when I went to go online