Overwatch 2 Beta Not Showing Up Solutions

First you MUST have watched one of the qualified Twitch streamers (OW2) for at least 4 hours yesterday, and the drop HAS to show up in your Inventory, this is a requirement for this solution

Started 1:10 am:

  1. If you tried everything and still didn’t get beta access to Overwatch 2 Tech beta (including checking connections, opting in, linking things, etc), try making your e-mail address the same on Twitch as it was on Blizzard. Confirm your email address.
  2. Setting up 2 factor authentication on Twitch (only need it on twitch).
  3. (during this period I elected to log out of my Battle.Net)
    Gave option to reconnect to B-net app on Twitch. (B-net remained connected to Twitch on its end.)
    3a. If your B-Net is still showing connected to Twitch. Hit disconnect. Then log out of twitch. Log back in, check your drops first, should prompt you to re-claim/connect B-Net.
  4. I got an option to reconnect my claimed reward in Inventory (Claim button is yellow, and Refresh button to the right of it. This button may show up more than one time)
    (Also it DOES NOT MATTER if it said Claimed before, it’s not “claimed” until it’s on your b-net launcher)
  5. Check your e-mail and verify your e-mail, then wait 30 mins to a few hours.
    (After 30 minutes on the dot, i logged back into the Launcher. and it appeared)

UPDATE: 6:35am checked Battlenet client, the menu HAS Overwatch 2 Tech Beta AVAILABLE in the drop down. It just takes a little time. NOT SURE HOW MUCH TIME but this DOES work.
Hope it helps you!!!

The install is 12gb, doesn’t take long on decent internet. About 20-30 min

Props to: Wow! for finding initial solution.
I added some updates on this, follow that directly and let me know if that worked, if not i will continue to help people trouble shoot options.

Other Quick Fixes:

  • An easy solution to this issue appears to be making sure Overwatch is installed, and booting it up.
  • Once open, simply close the game, click the Globe next to Game Version, and change your region to Europe. Then boot up to the start menu again.
  • After closing the game, check your Game Version menu again and the Beta may have appeared.
  • “from: Anurag Chawake”
1 Like

Bizz should hire us lil detectives :wink: haha, enjoy the game fam!

1 Like

Haha, hopefully that helps anyone! I’ll continue to monitor sporadically to see if anyone leaves comments/questions. Best of luck and hope to see you out on the field! Great work on the trouble shooting! :smiley:

1 Like

I started Overwatch 1 in alpha, I have like every skin, play every day, I mean it just didn’t feel right to not have ow2 beta, so I had to tryhard a solution

Honestly it began as me just messing with everything lol

1 Like

Haha, trust me bro, i was right there with you. it came out when i was a freshman in college, so it’s hard nostalgia for me. So happy to be up and rolling!

I also cross-tagged the posts on the actual overwatch forum where most people seem to be lodging their complaints so hopefully these gets some more traction!

1 Like

What do you mean by checking and verifying my e-mail?

If you updated your email on twitch/BNet you’ll want to confirm that email. Should send am email for verification. (Unless you opted to open up your twitch to allow multiple emails to be made underneath it, at which case it may not request you confirm it).

Example : I have two twitch accounts, the one that i had for my drop, was not the one i had under my b-net account. I opted to make it so i could have multiple twitch accounts connected to the same email. (therefore i did not get prompted with a validating my new email address.

I believe this was a different process than Wows initial go.

Oh I haven’t changed my email for twitch and I’ve been using that same email on battlenet for 15 years so I don’t believe I will receive a validation email.

None of this worked for me so far.

If you have checked each app is connected to eachother and claimed the drop on twitch and it still hasn’t shown up uninstall and reinstall battle.net I couldn’t even uninstall bnet I had to manually delete it then reinstall it fresh. Now i got it to show up. I even put a ticket in and they said log out for a while i did and had tried everything short of reinstalling before that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.