[Nov 10] Main Thread: Blizzard Desktop App crash

[Update: 4:55 PM (PT)] A fix has been applied to prevent these crashes. Users should not need to take any further action. Thank you all for hanging in there while this was worked on!

So battlenet has been working just fine… I updated Vanguard and now battlenet just keeps crashing. I have cleared the cache and all but it hasn’t changed anything. I even tried restarting my pc to see if that cleared anything but nope.

“The application encountered an unexpected error”

It does give me a report id if that will help


Same thing here, out of no where, I did no updates, just came back and it was crashed and will not stay open now.


I’m also just now getting this error, didn’t happen last night. It opens for about 3 seconds then closes with the error code 0A45F678-C43F-4DC9-A0D6-DF5299604684. I’ve reinstalled, run as admin, and disabled firewall for it.

1 Like

Same here, was working yesterday. Now today, it crashes within a few seconds of starting up. The latest Report ID I got was E51E916C-5637-413C-A30F-ACDDD9FFB629

For those playing World of Warcraft, you can still open the game in your WoW>Retail>Wow.exe - it skips the launcher and opens the game, but will require manual code from your authenticator.

Correct, I had to do this, just kind of random.

Same issue for me. Fortunately you can launch the game you want to play directly and log in through that and I had no issues getting into the game.

I also have this issue right now. The launcher just crashes instantly after my Vanguard Update.


Having the same problem. Stopped working out of nowhere

Thought I’d reinstall Battle.net and Starcraft II for some co-op games. Instead, my Battle.net app crashes almost instantly. Every single time.

At least it’s not just me. I don’t know if that’s… encouraging… but it’s good to know that this isn’t just my computer having weird issues.

1 Like

Also experiencing the same. Has anyone found a work around to launch Vangaurd? similar to the play file wow has?

1 Like

Same issue. The PC launcher crashes instantly. I am unable to launch any game even directly.

i as well am getting this issue. fine yesterday, today crashes. cant open app at all.

I have the same issue, happened in the middle of the Vanguard update, and I can’t find a fix for it.

at least im not the only one. blizzard please fix this

Same here cant connect since 30 minutes ago, it was working fine, it crashes instantly.

reinstalled the application entirely, currently using the Opt-In Beta client, still no resolution, application instantly crashes after sign-in

I sent a reply about me having the same issue like a minute ago, but now it works, I think they have fixed it. I recommend you all to see if it works now!

Same here, broke as of around an hour ago for me.

Still broken for me.