[Main Thread] The Battle.net Update Agent stopped at 45%

This is the correct answer. I was having a very similar problem (update freezing at 45%) but I had selected ‘English UK’ by accident instead of ‘English US’ (i.e. the problem can occur with other languages than Chinese as far as I can tell). It was only by taking these 3 steps that I could resolve it, regedit alone and/or changing language in ‘product’ file in Program Data didn’t do it, I also had to remove the Appdata folder.

P.S. - To other Australians, please remember we are in the ‘Americas’ and thus EnglishUS for battlenet purposes, I had clearly forgot…

1 Like

I am in the United States, but when I downloaded Battlenet, it kept showing zh-cn or zh-tw, and when I downloaded Battlenet, The Battle.net Update Agent stopped at 45%.


Copy folder C:\ProgramData\Battle.net from someone who can play/run battlenet corectly

this solution work for me

need more disk space on computer?

I don’t think so, because after I uninstalled battlenet, I didn’t download any apps on my computer.

Tried everything mentioned. On a windows 11 laptop. Tried changing the regedit, deleting all the files, restarting the computer, and resetting the router. Any help would be nice. Coming back to WoW after years of not playing and this is not a great welcome back.

1 Like

I have the same problem! It’s just to install Battle.net and not a game! There is a lot of space here for that launcher =/

1 Like

How has Blizzard still not fixed this? Pretty ridiculous if you ask me.

Stuck at 45% on an M1 Mac and with no idea how to resolve.

1 Like

Did you check the Mac forum? This one is for PC.

Pretty sure this forum is just for the desktop app. It doesn’t specify an OS.

1 Like

Same problem here, tried deleting files in /Users/Shared/Battle.net and running from the command line with --locale=enUS neither seem to work. I did notice it outputs some 404 errors which suggest maybe the URLs it’s trying to access for the update aren’t valid anymore.

<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="http://www.blizzard.com/404">here</a>.</h2>

I found the logs and it looks like this is where it’s getting stuck:

I 2024-01-19 04:47:49.472100 [Main] {0x700003c0f000} Bootstrapper State: STATE_CHECK_CLIENT
I 2024-01-19 04:47:49.572773 [Main] {0x700003c0f000} Bootstrapper State: STATE_CHECK_UNREGISTERED_CLIENT
I 2024-01-19 04:47:50.077901 [Main] {0x700003c0f000} Bootstrapper State: STATE_CHECK_CLIENT
I 2024-01-19 04:47:50.077953 [Main] {0x700003c0f000} Bootstrapper State: STATE_INSTALL_CLIENT
D 2024-01-19 04:47:50.078032 [BSAgentManager] {0x700003c0f000} Waiting for user to finish installation configuration.
D 2024-01-19 04:47:51.248524 [Main] {0x7ff84beb4340} UpdateInstallStatus
D 2024-01-19 04:47:55.198759 [Main] {0x7ff84beb4340} UpdateInstallStatus
D 2024-01-19 04:48:00.478090 [Main] {0x7ff84beb4340} UpdateInstallStatus
D 2024-01-19 04:48:05.428756 [Main] {0x7ff84beb4340} UpdateInstallStatus
D 2024-01-19 04:48:10.378007 [Main] {0x7ff84beb4340} UpdateInstallStatus
D 2024-01-19 04:48:15.328714 [Main] {0x7ff84beb4340} UpdateInstallStatus
D 2024-01-19 04:48:20.607749 [Main] {0x7ff84beb4340} UpdateInstallStatus

There’s some installation configuration that never appears in the UI, but seems like the program is waiting for input from that to move forward.

The lack of specification should probably be addressed in the name, that’s true. But they are separate forums.

Is there a way to get an official answer for this from the support? Like it is a known issue or they are working on it etc…

1 Like

FYI i created a ticket with every info that we’ve got, and got an answer for it.

It seems there’s an issue currently affecting the Battle.net app on Mac. Our team is aware of it and investigating.

So atleast it is in the investigation phase, hope they will fix it soon.


This is probably an request limit for specific IPs.

The only solution I can think of is to determine which DNS Entry we have to change and which are the possible IPs and try(manually changing the hosts file) till it works or just wait till its your turn…

This is probably why changing the language solution sometimes works. They have different DNS entries for different locations meaning cn.patch.battlenet … resolves to IP1(limited) and en.patch.battlebet resolves to IP2(maybe not limited).

Thank you sir! Same errors and logs like Arthyn. Apple M1 Pro with Sonoma 14.2

Same error logs for me too, stuck at 45%

Apple M1 Pro - Sonoma 14.2.1

1 Like

Same issue here. Max M2, Sonoma 14.2.1.

Agent logs just have this over and over:

[I 2024-01-19 13:14:36.0148] Duplicate POST /install/battle.net completed in 0.7550 ms
[I 2024-01-19 13:14:41.0190] Duplicate POST /install/battle.net completed in 0.4770 ms
[I 2024-01-19 13:14:46.0236] Duplicate POST /install/battle.net completed in 0.4960 ms
[I 2024-01-19 13:14:51.0278] Duplicate POST /install/battle.net completed in 0.4820 ms
[I 2024-01-19 13:14:56.0314] Duplicate POST /install/battle.net completed in 0.4710 ms

BC logs:

[I 2024-01-19 13:11:15.0048] [tact] Adding server node 8. Server 'level3.ssl.blizzard.com' | Address ''
[I 2024-01-19 13:11:15.0048] [tact] Adding server node 9. Server 'level3.ssl.blizzard.com' | Address ''
[I 2024-01-19 13:11:15.0050] [tact] Adding server node 10. Server 'us.cdn.blizzard.com' | Address ''
[I 2024-01-19 13:11:15.0050] [tact] Adding server node 11. Server 'us.cdn.blizzard.com' | Address ''
[I 2024-01-19 13:11:15.0050] [tact] Adding server node 12. Server 'us.cdn.blizzard.com' | Address ''
[I 2024-01-19 13:11:15.0050] [tact] Adding server node 13. Server 'us.cdn.blizzard.com' | Address ''
[I 2024-01-19 13:11:15.0050] [tact] DNS resolution completed in 111ms.
[I 2024-01-19 13:11:15.0050] [tact] Downloading config with key 83509ad99a0756fe23adacd86b72b264. Existing file is missing or invalid.
[E 2024-01-19 13:11:15.0084] [tact] Failed to create config directory config/83/50. Error (100030): Read-only file system
[E 2024-01-19 13:11:15.0084] [tact] Failed to read build config '83509ad99a0756fe23adacd86b72b264'. Error (1): unknown failure

That read-only filesystem is apparently the one that the installer itself uses:

/Users/myuser/Downloads/Battle.net-Setup.app on /private/var/folders/4q/swbvsgxs0vv57yq9fc2l0j4r0000gn/T/AppTranslocation/5DB69389-9C90-494E-873D-E6BDC913E352 (nullfs, local, nodev, nosuid, read-only, nobrowse, mounted by myuser)

Tried all the usual stuff: reinstall of everything, nuking preferences, VPN, updating permissions, etc. No difference. Stays at 45%

Same here…just got home with a brand new mbp m3 max…tried all stuff written on WoW and Battle.net forums, nothing helps…