[Main Thread] Scanning and Repairing Repeatedly After Bnet Update

Tonight I was prompted to download a small update to the battle.net launcher, something about voice transcription and the like, whatever.

Anyway after downloading it and letting it do its thing, my WoW scanned and repaired itself. Okay fair enough, I run the game without issue, shut it down, and then exit out of battle.net. When I relaunch the desktop app my WoW is once again scanning and repairing.

Now every time I shut down and re-launch Bnet my WoW scans and repairs. I tried deleting all the .idx files in the data > data folder as is suggested and then running a scan and repair. It went fine but then as soon as I shut down Bnet and relaunched it, I was once again scanning and repairing.

I was able to x out of the scan and run wow anyway and it seems to be running normally, but I’d like to get to the bottom of this and stop it from happening in the first place.

Any help resolving this would be appreciated.

EDIT: After seeing some of the other threads I feel like I should clarify. My WoW only scans and repairs once so far, and then seems to be fine UNTIL I close battle.net all the way and re-launch it. Then it scans and repairs yet again. I’m not getting stuck in an infinite, non ending loop, and I’m not getting any error messages. But it IS acting as a gatekeeper, forcing me to do it before each time I play wow at the moment.

Edit 2: Rebooting and other options didn’t fix it. It also seems to happen any time I click on the WoW or WoW Classic shortcuts on my desktop, even if Bnet was already open and had scanned previously. And now that I’ve rebooted it scans, but tells me no repairs are required each time.

14 Likes

I am having the same issue after a update. I’m not very keen on having to do a reinstall, as much as I love WoW. Nothing else has changed and the game runs, has seemed to, just fine in time meantime.

Same problem here in Canada. I had tried to fix it for the last 6 hours but no luck.
Uninstalled Battle.net and reinstalled it didn’t fix it. Scan and Repair didn’t fix it.
Delete the cache didn’t fix it.

ya u got the same thing i dont know whats up with blizz but the game is realy going down hill

It’s really really really really really really really really really really annoying

2 Likes

same thing, except when i hit x to stop scan second time, it starts to load in server all graphics jump around and i have a large white box where game should be and a white rimmed box where launcher should be

Checking in to say that I’m having the same issue after updating my Battle.net app.

It’ll scan the files for about 5 mins, then say it’s installing files, (nothing new actually gets installed) then goes into ‘finalize’ phase and then after all that - I can play the game.

This is happening every time I launch the Battle.net app to play WoW.

Throwing my hat into this ring - same issue, exactly. Started yesterday.

yep same, 10 mins to start a game gets annoying very quick.

Yeah I thought something screwy was happening on Overwatch after migrating my NVME drive to a new computer, but when it happened on a second computer I knew something was up.
Glad I can stop trying fixes.

Problema de reescaneo, estoy teniendo exactamente el mismo problema, desde el martes pasado, que se puede hacer?

Same problem here. Just do not shut down launcher :smiley: … yes … it is annoying :open_mouth:

Adding my name to the list. Annoying >.>

Same problem on Modern Warfare since update to Battle.net today. I only have issue if I run Modern Warfare from desk top short cut. If I run short cut to Battle.net and run Modern Warfare through it, no problems.

1 Like

I am having the same issue too.

Im having the same issue but with Hearthstone. Every time i open Battle net it starts the scan and repair

Scan Loop did everything include re-load game - worked once and shut down and back to scan loop - why

I’m also stuck in a scan loop. Can we fix this please?

Exact same issue here.

It scans every time I launch Bnet and even worse the scan will start in a middle of playing WoW and boots me out of the game.