Main Thread. Blizzard Agent went to sleep. Attempting to wake it up

I’m also having the same issue. I currently have an update downloading (KB4551762) so I’ll edit this after that has installed and edit it once more if uninstalling the update I had last night (KB4540673) has any effect on this problem.

Edit: Removed both updates, no impact and same issue. Can just start your chosen game directly for now until it’s fixed.

1 Like

+1 to the issue.
@Simoneb92 Twitter account is active

1 Like

Same here. Some friends are on Wow or Overwatch. Since that Overwatch patch update I can’t seem to go to my games.

1 Like

Same error here. Whatever happened killed my entire internet for a few minutes too.

Hey guys, to bypass the Battle.net launcher, run " C:\Program Files (x86)\StarCraft II\Support\SC2Switcher.exe" :slight_smile:

14 Likes

Having the same issue here. Also tried launching the game directly, still not working. And here I was hoping to knock out my Challenge Rift in prep for D3 season 20. RIP.

3 Likes

Something on Blizzards end is sporked.
I was able to play after the Windows Update & reboot yesterday.
I played about an hour ago.
Now its asleep…

3 Likes

Same issue here.

Tried the following to no effect:

  • Restarting pc
  • Terminating all battle.net processes in Task Manager.
  • Deleting battle.net and Blizzard Entertainment folders in %appdata%
  • Downloading installer and reinstalling client (got stuck on downloading files for 5 minutes, before returning to same error)
7 Likes

Yeah same here. Maybe the windows update has something to do with it.

1 Like

i do not have a twitter account. I cant contact them through mail or chat here on website… you the same?

1 Like

same lmao after updating windows this happened what a joke…

2 Likes

Same worked when earlier around 7 but now its sleeping lol. i didnt do any windows update on my side so i dont think this is the issue i think its on blizzard side

1 Like

+1 … same issue for me. Was working this morning, did a Windows update and no longer working.

Oh, interesting. Right click the bnet app icon in the task bar drawer. It offers no gamed but it does have a grayed out “pause all downloads” which isn’t normally there.

Same problem :frowning: . So sad rn. Cleaned my room today and fixed some stuff and the entire day I was looking forward to play overwatch. Waiting 20 minutes doesn’t help, restarting my game or pc also doesn’t work…

1 Like

You need to bypass the Battlenet App

Go & load from WoWclassic.exe and put in your email/username & PWD

4 Likes

Only through contact form, not phone or live.

Dangit, I was looking forward to playing some MW Warzone… Let’s bust in the BattleNET headquarters.

3 Likes

same here app is in sleep mode

I’m having the same issue. Could the windows update have something to do with it ? I wouldn’t think so since so many people are having issues but i guess its a possibility