[Main Thread] Agent Went To Sleep BLZBNTBNA00000005

I too get the "Agent went to sleep, tried AAALLL the recommendations I could find on the internet to no avail. Constantly, “waiting for another update” then it “updates” and then says “Warzone now Playable” allows me to launch into a game, and then freezes right in prelobby and kicks me out with no error message whatsoever, and then starts to “Update” in the exact same sequence as mentioned above. (That Being Said: I did do a fresh RE install of everything Including Windows 11, and all necessary drivers and updates…and downloaded and installed nearly 600gigs of Call of duty Games (V,MW,BO).

Like everyone else here, it’s now September 2022, and it seems I’m also the latest victim that apparently, “Agent went to sleep…” I’ve also tried exactly what everyone else was prompted to do, yet here I am…


I decided to reinstall the App and now I’m experiencing that too.

1 Like

Not a full fix but a major improvement:
-Once I got battle.net update agent unasleep, I…
a) found it in task manager Processes and right-click
b) Select Properties and go to compatibility tab
c) Tick run this program in compatibility mode and select Windows 8
d) apply, ok, right click again, end task, relaunch

Now the error only displays for 10-13 seconds, and my in-game friends list being empty and non-interactive, which seemed possibly related, has apparently stopped happening

Windows 10 Home here.

Upgraded to windows 11 weeks ago. Now ‘‘Battlenet agent went to sleep’’

Tried everything on the support pages and more nothing works.

Cant even uninstal the app because it wants to update first but it cant.

1 Like

Hello, tech support please help.
I tried many solutions from this forums and google, but still can not solve this problem.
I tried to format my PC and reinstall windows but still same problem.

Question is, if you can not help me solve this problem, can I ask to refund all the money I spent to this game?

Please help (fix).



I’m having the same issue on my end.

I did reinstall BNET, reinstalled network drivers, renewed DNS, restarted my router… basically everything Blizzard mentioned would “fix” this issue.

It’s on their end, not ours. We cannot do anything about it.

Same problem here.

I also jumped through all the hoops of suggested fixes, and nothing provided a resolution. My launcher is still displaying the error message, even after letting it sit there for over an hour.

After reinstalling BNET, it did let me past the error message after the first launch, but got stuck on “waiting” to download the update with the game unplayable. After restarting my computer, it was back to the “Agent went to sleep” error.

It definitely seems like this is on their end.

If Battle net cannot fix Error BLZBNTBNA00000005 I also would like my money refunded. I cannot play any Diablo game, not Diablo Immortal, Diablo III nor Diablo 2.


Same issue here. Trying to play Modern Warfare 2019, getting the same error. Must be system-wide rather than tied to specific games or accounts.

1 Like

have you got it fix
because my was doing the same thing
i have scan and repair i just want to play warzone

I have the same problem.

The same problem here… yesterday I was using it normally, but today (09/19/22) the thing doesn’t want to work anymore, I’ve done everything to try to fix it, I even uninstalled it to try to fix it, but now it can’t even install it, it is currently stuck on “updating the battle net update agent”… this is being very frustrating.


I’m having the same issue today. Can’t do anything with the Battle.net app and it is unable to update OR uninstall…


On the side note. Battle.net app takes ages restoring from the system tray when I quit any of my games. Also for some strange reason App is installing .battle.net folder in my game folders. Not to mention problem with the “Agent went to sleep” still keeps going.

1 Like

24 hours with this problem and no solution appears. Disappointing.


Just to comment, there’s a thread with people running Battle.net in wine (or on Steam Deck in Proton) with people having problems with Agent.exe update of last couple days too. Thread I was running the same wine-7.0 version before and now, so no worries you didn’t get a Windows update, firewall update, or antivirus update that is messing with it. :slightly_smiling_face:

Good hunting finding that bug!

I’m now experiencing this issue. Haven’t had time to run any of the troubleshooting steps yet.

1 Like

I seem to have resolved the issue. With Battle.net Launcher closed. I tried starting the Agent.exe file manually, first tried opening C:\ProgramData\Battle.net\Agent\Agent.8012\Agent.exe but I got a Window Error message stating that the app couldn’t be launched. (Sorry, didn’t record the exact message.) I then tried running C:\ProgramData\Battle.net\Agent\Agent.8009\Agent.exe. This app loaded and when I started the Battle.net Launcher I got back in. The Launcher did need to scan for games again.

I later checked the Task Manager and the Battle.net Update Agent was now running the 8012 version. So it seems that version may have been corrupted and running the old version allowed it to be repaired and the client began using that version again.

Also, I will note that I previously renamed the C:\ProgramData\Battle.net\Agent\data\cache to cache.old, which may be the reason I had to do the scan for games again. If running the older Agent.exe alone doesn’t work for you perhaps delete or rename this cache folder as well.

I will note, that I’m still getting the Agent went to Sleep message when starting up, but now the message is disappearing after 15-20 seconds or so.

This is what’s happening to me too, for some reason after the last update, the agent became very slow, it takes almost 1 minute to “wake up” and takes a really long time to do any update or scan activity, gets stuck with “Waiting”, “Initializing” messages… Also, it ignores any limits I set in the download config and takes a long time to refresh current DL speed

Fixes I already tried:

  • Run Battlenet as administrator
  • Reinstall Battlenet including deleting folders in %programdata% %temp% %localappdata% %appdata%
  • Disable anti-virus
  • Scan and repair each battlenet game installation
  • Rebuild Windows WMI
  • Change public IP address, DNS, in router config
  • Disable firewall in router config and Windows

Ok so I found out that if I disable “Limit download bandwidth” in Battlenet app, the update agent starts working as expected… So, I’m guessing that the last update broke something regarding that option in the app config