[Main Thread] Agent Went To Sleep BLZBNTBNA00000005

Everything I’ve already tried:
Uninstalling/Reinstalling Battle.Net as well as all Blizzard/Activision games.
Did a fresh Windows 10 install with fresh partitions for every drive.
Tried Port Forwarding, disabling all firewalls, and all anti virus programs(Malwarebytes).
I tried running as Admin, making a new admin account, and checking Windows permissions.
I tried essentially EVERY possible solution recommended on the battle.net forums, and under support.
I tried with and without a static IP.
I also tried the normal version of battle.net and the beta.

One thing I DID notice:
It looks like the database file in C:\ProgramData\Battle.net\Agent gets corrupted because if I delete the .product file it loads up the Battle.Net launcher without the error. Once I go back into the settings and select the default install directory, or choose a game location’s install folder then it causes the error to come back on my next battle.net launch. I’ll go delete that .product file again, and it’ll load up without issues. So it seems to be in relation to the .product file?

13 Likes

I have the same exact issue.

I just started having the exact same issue today

I have had the same issue for a while. and the updates dont update if something is updating (and it’s not on the app) in the background - good luck finding it. restarting doesn’t fix the issue, also trying all the other website advice either doesn’t. I have suggested it’s a conflict with the W11 coding or newer PCs months ago (with slightly different phrasing), but no one has bothered to look into it. Seems wont be playing any blizz games for a while.

1 Like

I found a fix that worked.

4 – The fourth Blizzard Agent went sleep fix we have for you involves clearing the cache. Here is how to do so:

Exit the Blizzard launcher.
Launch the Task Manager, confirm if both the launcher and Agent are ended. If they haven’t been, do so.
Click Windows + R to open the “Run” window.
Input “%programdata% into the open window
Click “OK”
Search for Blizzard Entertainment and Battle.net folders in the Program Data folder that will come up, then delete them
Exit the window and restart the launcher
You should know that when you restart the launcher, it might not detect your games. If this occurs, don’t panic. Simply click on the “Locate the game,” which you will find this beside the “Install game” button. Then, navigate to the previously downloaded game folder. Once this is done, you can expect everything to go back to normal.
16 Likes

Turns out it breaks again on close

[E 2022-09-09 01:45:33.0987] Failed to download url "http://us.patch.battle.net:1119/osi/bgdl?nocache=2592968176"
[E 2022-09-09 01:45:49.0166] Failed to download url "http://us.patch.battle.net:1119/osi/bgdl?nocache=622662592"
[E 2022-09-09 01:46:44.0855] Failed to download url "http://us.patch.battle.net:1119/osi/bgdl?nocache=444869644"
[E 2022-09-09 01:47:36.0438] Failed to download url "http://us.patch.battle.net:1119/osi/bgdl?nocache=513943392"
[E 2022-09-09 01:48:23.0998] Failed to download url "http://us.patch.battle.net:1119/osi/bgdl?nocache=813377436"
[E 2022-09-09 01:49:23.0773] Failed to download url "http://us.patch.battle.net:1119/osi/bgdl?nocache=468767292"
[E 2022-09-09 01:50:20.0194] Failed to download url "http://us.patch.battle.net:1119/osi/bgdl?nocache=1058913144"
[E 2022-09-09 01:51:20.0185] Failed to download url "http://us.patch.battle.net:1119/osi/bgdl?nocache=915568200"

Looks like it can’t connect to the patch server even though it could yesterday

Yeah, but next update it breaks again. It needs a permanent solution. Which I have been telling them for months. And it seems to be a W11 or a particular brand or motherboard issue maybe? Though, I have said this previously. Though, no one has looked into it. It’s just go to the fixes. Until, it comes back again. Now, it’s really broken. I have tried everything, and even restarted my PC, and can’t update my games. So that means, I can’t get to my expiring mail in games like wow etc (because I can’t play).

1 Like

I’m not on windows 11 and everything was fine yesterday.

It’s an issue with the connection to the update servers. what region are you in? I’m in central US

Yes, I understand that. I am just saying that it seems to be a constant thing that continues to happen with W11 since I installed last year, mind you only with BNET app. All the other applications don’t persist with ‘it went to sleep’ or ‘waiting for another app to update’ (even when there are no other games updating) so it may hang for many hours. And sometimes I get lucky and restart the PC and it starts the DL, but that option has gone now, so I cannot update or play like I said.

Happens to me on both a clean Windows 11 and Windows 10 install.

Just another little update, here is a winmtr to us .patch .battle .net

|------------------------------------------------------------------------------------------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                     www.routerlogin.com -    0 |  194 |  194 |    0 |    0 |    0 |    0 |
|             50-80-16-1.client.mchsi.com -    0 |  194 |  194 |    3 |   13 |   82 |   12 |
|                           172.30.11.113 -    0 |  194 |  194 |    8 |   12 |   81 |   12 |
|                              10.16.72.1 -    0 |  194 |  194 |    9 |   14 |   82 |   12 |
|            68-66-73-64.client.mchsi.com -    0 |  194 |  194 |   24 |   28 |   97 |   27 |
|              po13.chgil001cr1.mchsi.com -    0 |  194 |  194 |   24 |   28 |   97 |   28 |
|              po10.chgil001er1.mchsi.com -    0 |  194 |  194 |   24 |   29 |   97 |   28 |
|                          137.221.66.164 -    0 |  194 |  194 |   24 |   33 |   98 |   27 |
|                   No response from host -  100 |   40 |    0 |    0 |    0 |    0 |    0 |
|                   No response from host -  100 |   40 |    0 |    0 |    0 |    0 |    0 |
|        et-0-0-0-pe02-swlv10.as57976.net -    0 |  194 |  194 |   61 |   66 |  134 |   64 |
|       las-swlv10-ia-bons-02.as57976.net -    0 |  194 |  194 |   61 |   65 |  135 |   65 |
|                          137.221.105.15 -    0 |  194 |  194 |   58 |   66 |  134 |   64 |
|                          137.221.106.19 -    0 |  194 |  194 |   61 |   65 |  134 |   64 |
|________________________________________________|______|______|______|______|______|______|
   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

same exact issue! wtf

It looks like this solved it for me. When I deleted the .product file, I opened the launcher and it wasn’t “sleeping” this time. It was trying to update Wrath classic. The update wasn’t starting for me at first, so I clicked the settings button next to the play button, or the button that said Updating at the time, and then clicked scan and repair. It took a good bit, 10 -20 minutes, but when it finished, the update button lit up again and when i tried it this time, it worked. After I made sure all the games were fully updated, I closed out the launcher to see if it would boot back up and it did with no problem. So thank you so very much. I haven’t been able to play in two days.

My ISP rolled out IPv6 two days ago and it seems that this issue resolved itself around that time. I am not sure if there was some routing issue that got solved by getting a new IPv6 address or what from the rollout but so far so good.

I have the same error coming up. I have litterally tried everything. Even reinstalled battle net app twice. I have Windows 10. Nothing helps, it works momentarily when I make ipconfig /release …/renew… and later /flushdns

Only to again crash all over - TIRING! I’m wondering about my money… sincerely now. I paid for this game.

2 Likes

bro mine says it needs too update and it says error everytime i try too update it

I’m experiencing the same issue(s). I can log into the app. I can actually click and see the store. But, I’m getting BLZBNTBNA00000005 when I click on games. It says the update agent is asleep. This is incredibly frustrating.

3 Likes

Same here . I applied the latest update. played 1 time and it froze. Restarted computer scan &repair several times same error BLZBNTAGT00000960. OOps… Any help??[quote=“GotniMo-1164, post:1, topic:8544, full:true”]
Everytime log in BLZBNTBNA00000005. I cannot play any games at all. Please fix this!
[/quote]

I just had the same issue and tried everything on the list blizz provide on
us.battle.net/ support/en/article/16531
But what fixed the issue was of course not on the list.
I removed the Battle.net folder from the AppData folder which you can acces by doing windows-R and type C:/ProgramData
Quit battle.net app, Find your Battle.net folder, delete it, and launch the battle.net app.

I hope it will help !

9 Likes

Had the same issue. Restarting didn’t help, running as administrator didn’t help, and I sure as hell wasn’t going to disable my security programs. So a week goes by and I try the solution Kharga gave above (though I did have to delete both the Battle.net and the Blizzard Entertainment folders).

And it worked. Took less than 2 minutes to implement, then things ran smoothly. And even if it comes back again (as I have heard it can), I can just do it again, and again, till Blizz fixes this.

So thank you Kharga, for a nice, simple, WORKING solution.