Diablo 2 - Cannot connect to battlenet

Good Evening,

I just downloaded & installed D2 & D2 LOD for the first time will well over a decade. I am using my key codes from my original CD’s (redeemed them on battlenet for the 26 digit key) and I am having the same issues as many others. I keep getting the “Battlenet is not responding. Please try connecting again in a few minutes.” I am getting this error on all gateways. I assume I have been banned for no apparent reason and would just like to know what the issue is.

Thank You.

You were IP banned like thousands of the rest of us. Please advise… update we need this to get seen

It does not get anymore activision/blizzard then that… But that is how the older diablo games and the majority of their titles have been managed. I ran into all the same issues with my copy of diablo 2 and LOD… Not a single positive thing came from the experience with blizzard.

The worst part is they literally could care less… these forum posts about the game not working for people who has JUST purchased it… I can’t even describe my frustration other than in my past dealings with them. I wish you and the rest of the D2 community the best of luck.

I just got off the phone with blizzard support after 5 days of fighting this issue, attempting to install the game from the blizzard site to immediately not being able to log in. The reasoning blizzard provided was that there was activity on my IP address associated with China… basically they said we have no idea and we can’t figure it out so we are going to give you the most generic bull crap response we can draw up.

Multiple friends who just purchased the game and have never even attempted to play are also IP banned they must’ve been in cahoots with China as well. I’m baffled by the customer service and they all need fired

Listen up!!
There have been seriouos rumours that China is planning to take over the world… Apparently this is only the beginning…
No kidding… With that kind of service, you can keep the customers in the dark as long as you want… There has been a mistake somewhere and apparently it’s extremely difficult or costly to repair it… meanwhile… keep on fooling your loyal customers…

Hello. Well, I’ve had some troubles myself. Is your client updated to 1.14d?
If not, download and install the 1,14d patch and try again.

Choose Diablo II and download the suitable patch (if you have LoD or not, just choose one). Install and try again. Worked for me.

Sorry if you already tried that, didn’t have time to read the whole topic.

Good Luck!

Yep. Same problem here. I just purchased the game too. Banned for zero reason. Would be nice if Blizzard did something to fix this issue because I’ts been 2 days now. I understand it’s a old game. But I didn’t have this issue back in the early 2000’s. I’m not using a VPN. I’m not cheating or anything crazy. Just tried playing the game that I paid for.

Along with all of us and they are treating us like criminals in the matter… I finally got ahold of support 5 attempts and still got absolutely no where they just said wait out the ban and then decided that they were some righteous a$$ holes that could tell me without knows their a$$ from a hole in the ground that it wasn’t ME who broke rules it was my IP address (prior to having the game installed, or playing, or creating a character, or doing anything at all) so the best blizzard can tell you is contact your ISP because they did it…

PLEASE READ THIS MAY HELP YOU FIX YOUR ISSUE

y’all I have been having the same issues with first time logging in and timing out - I used my iphone as a hotspot while connected to my home wifi and plugged it into my computer to use as another router - with the new IP address I was able to log in fine and play for hours. not sure if this will solve all your problems but it’s letting me play on battlenet without any problems now!

[Edited by Moderator]
This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.