Cannot update WoW TBC - don't have administrator rights

2018 Macbook Pro. This is also happening to me. I was on Big Sur (11.0) when the error occurred on November 11th. I have tried reinstalling and WoW Classic TBC (Retail WoW works), but neither reinstall fixed this. I then tried to update to Monterey (12.0) and it is still having the same issue as described below.
The client tries to update TBC Classic and has a popup from “Agent wants to make changes” saying I need to login with my computer password. After that the update fails at “fetching game config” and then give me an error .
Error: BLZBNTAGT00000BB8

1 Like

Well? Where is the update on this? YOU RUN A SUBSCRIPTION SERVICE, this is NOT ASCCEPTABLE. Start getting refunds ready thieves!!! Maybe change run to ruin in that earlier sentence ALL the Shenanigans in Blizzard’s culture happening RIGHT NOW and you cant even get the basics of the launcher right, or give us information on how long YOUR MISTAKE will take to fix. WE KNOW this is YOUR mistake. Yesterday this launcher worked and then STOPPED WORKING, that means YOU DID THIS. YOU DID SOMETHING!!! It could not have happened on our end the way this is playing out, you know that already, so admit it. that is the first step to fixing it, admitting you did it. You are not fooling us, stop thinking we are stupid, admit you screwed up. Admit you don’t know what you are doing. Give us remuneration for YOUR mistake, because you are not providing us a service we already paid you for. RETAIL AND TBC BOTH BROKEN, you mental midgets, go back and find what you broke


Mac user, with same issue. Same error code and unable to update classic, but am able to update SC and WC3.

This solved it for me !

In my Agent folder there is an Agent app, then two folders (Agent 7531 and Agent 7581).
I went into the Agent 7531, started that version of Agent, then started app and everything works as expected! Thanks!


Some devs need to be fired.


Starting from Agent.7531 worked for me as well, but it reset all of my addons.

it’s haven’t worked for me… tried a reinstall of Bnet and it’s the same

I also cant update. :frowning: on mac desktop 10.13.6

edit* just tried my macbook, able to log in without issue. no need for forced update or hassle.

What i needed to do was to start the activity monitor. and kill all the agent processes. once that was done, start the Agent.7531 and it is updating right now.

Many thanks. Using Agent.7531 worked for me, too. Big mystery is why there are multiple Agents and why the one that was called by default (Agent.7581 ? ) wasn’t working.

I’m stuck, i no more have the 7531 version…

1 Like

If you’ve been running Time Machine, maybe you can get a backup from there.

I tried scan and repair yesterday and this morning, kept getting the error code. It would not do anything. I tried it again about 20 mins ago, and the function was working and has, at least temporarily, fixed the “not an admin” issue for me. running a Mac M1 2020 OS 12.0.1

is there any update to when this will be fixed on mac and on windows blizz tec said it would be fixed asap i payed for 2 months of game time now just taking money plz give an update

1 Like

Submitted I needed help with this issue, then got a ban hammer stating I bought gold???
About to terminate subscription this is rediculous.

Unfortunately for me I only see Agent.7581 in the folder ya’ll were talkin bout … feelsbad

If you are running Time Machine you can recover it. It works !

Temporarly for me renaming/deleting sc2 docs folder finally worked (e.g. rename it to old_Starcraft2 to keep all account settings, replays for later recovery) with battlenet and agent.exe processes turned off in the task manager. Then when battle net starts, sc2 update was paused, after proceeding with the update, it has finally unstuck and make game available to play. Then you can copy all content from old_Starcraft2 to newly created folder Starcraft2 in docs to recover all accounts data, gl hf.

Figured out a fix this AM for me at least…it requires reinstalling the games…

Close out of App
Go to Finder → Mac HD → Users → Shared
Delete the folder
Open App, a re-install all games.