Cannot update WoW TBC - don't have administrator rights

I was trying to log into game for a raid the team needed me to be at, and I found I can’t update or install anything because bnet thinks it doesn’t have administrator privileges. I have:

-Run as administrator
-created a new administrator account
-disabled all background processes
-disabled my security programs
-uninstalled and reinstalled bnet
-deleted the tools folder
-uninstalled my addon program
-restarted my computer (multipled times)

Nothing works. This is terrible as many people needed me to be online today. I would really appreciate it if someone can help me.

Basically tried everything in these articles.
BLZBNTAGT00000841 - Blizzard Support (battle.net)
Unable to Install or Patch World of Warcraft - Blizzard Support (battle.net)

11 Likes

Same issue is happening for me except the problem is happening for retail, I also tried going into Classic and Classic TBC with the same issue. They all want me to update from the Battle.net launcher and then it tells me “Please try again after logging on as an administrator.” after putting in the administrator password and being logged on as the administrator.

Not sure if it matters but I’m playing on a Mac running Big Sur, the error code is BLZBNTAGT00000841

4 Likes

Hey all,

We’ve gotten several reports on this and it is currently being looked into. For the moment I’d like to see if this works:

  1. Right click the games folder
  2. Choose Properties
  3. Swap to the Security tab
  4. Select your user account
  5. Click Edit
  6. Tick Full Control then click OK
  7. Click OK again > then Apply changes to this folder, subfolders and files > click ok again

Once done restart the app and see if it allows the patch to work.

1 Like

It’s affecting macOS, not Windows as far as I know. It’s not affecting every mac user either. :frowning:

2 Likes

Which games folder? I’m using a Mac. Is this in the launcher? Or in the finder under the wow application or bnet launcher app?

1 Like

same issue here, uninstalled TBC, now it won’t let me install it now. MAC OS

all users of the folder have read and write ability, still nothing

Same problem here as well. Just started today. Played yesterday without a hitch. Can manually go the WoW app and start it, but battle net app is stuck on needing administrator rights to do anything, including scan/repair when only admin accounts exist on my mac. Battle.net is set up to allow all incoming connections on the Sec/Priv Firewall Tab. Settings unchanged for years. Something has altered the battle.net app’s function. Please help!

4 Likes

Same problème, MacOs 12.0.1 after launching classic era for name reservation, Battle net asking for administrator rights and any wow game can be launched (even if i give him sudo rights)
I can some times have the error : ERROR #154 (0x8510009a)
when launching the game without BN launcher

Same problem but with updating SC2

1 Like

Same problem but with updating SC2. Tried everything on this post but didn’t work

3 Likes

I’m having the same issue on Mac (12.0.1). WoW (Classic and Retail) cannot update and I get prompted for admin permissions. Attempting to launch WoW directly gets me this output (http and https modified to avoid becoming links…):

The CAS system was unable to initialize: ClientHandler: initialization error: failed fetching the build configuration file

ClientHandler: initialization error: failed fetching the build configuration file

ClientHandler: initialization error: failed fetching the build configuration file

tact::ClientHandler::Create failed: E_IO_ERROR
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.4:80 for server h t t p://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.6:80 for server h t t p://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.5:80 for server h t t p://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.3:80 for server h t t p://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.7:80 for server h t t p://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.2:80 for server h t t p://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.1:443 for server h t t p s://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.8:443 for server h t t p s://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.4:443 for server h t t p s://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.6:443 for server h t t p s://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.5:443 for server h t t p s://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.3:443 for server h t t p s://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.7:443 for server h t t p s://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 137.221.64.2:443 for server h t t p s://us.cdn.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 8.252.195.11:443 for server h t t p s://level3.ssl.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 8.252.43.139:443 for server h t t p s://level3.ssl.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 8.252.68.11:443 for server h t t p s://level3.ssl.blizzard.com/
[20211111T14:40:54] {1935342} INF: adding network address 23.220.167.67:443 for server h t t p s://blzddist1-a.akamaihd.net/
[20211111T14:40:54] {1935342} INF: adding network address 23.220.167.81:443 for server h t t p s://blzddist1-a.akamaihd.net/
[20211111T14:40:54] {1935342} INF: NameResolutionComplete numServers 5 numHosts 26
[20211111T14:40:55] {1935169} INF: initializing LRU status
[20211111T14:40:55] {1935169} INF: Initialization step - FETCHING_CDN_CONFIG
[20211111T14:40:55] {1935169} INF: Initialization step - FETCHING_BUILD_CONFIG
[20211111T14:40:55] {1935169} ERR: failed to open file ‘…/Data/config/78/0c/780c312bebf3e93ba8d0f53bd42f2c49’ in QA_READ_DATA query: Permission denied [13]
[20211111T14:40:55] {1935169} WRN: failed to fetch file ‘780c312bebf3e93ba8d0f53bd42f2c49’ (build config) (flags = 0x0): E_IO_ERROR
[20211111T14:40:55] {1935169} ERR: failed to open file ‘…/Data/config/78/0c/780c312bebf3e93ba8d0f53bd42f2c49’ in QA_READ_DATA query: Permission denied [13]
[20211111T14:40:55] {1935169} WRN: failed to fetch file ‘780c312bebf3e93ba8d0f53bd42f2c49’ (build config) (flags = 0x0): E_IO_ERROR
[20211111T14:40:55] {1935169} ERR: failed to open file ‘…/Data/config/78/0c/780c312bebf3e93ba8d0f53bd42f2c49’ in QA_READ_DATA query: Permission denied [13]
[20211111T14:40:55] {1935169} WRN: failed to fetch file ‘780c312bebf3e93ba8d0f53bd42f2c49’ (build config) (flags = 0x0): E_IO_ERROR
[20211111T14:40:55] {1935169} ERR: failed to open file ‘…/Data/config/78/0c/780c312bebf3e93ba8d0f53bd42f2c49’ in QA_READ_DATA query: Permission denied [13]
[20211111T14:40:55] {1935169} WRN: failed to fetch file ‘780c312bebf3e93ba8d0f53bd42f2c49’ (build config) (flags = 0x0): E_IO_ERROR
[20211111T14:40:55] {1935169} ERR: failed to open file ‘…/Data/config/78/0c/780c312bebf3e93ba8d0f53bd42f2c49’ in QA_READ_DATA query: Permission denied [13]
[20211111T14:40:55] {1935169} WRN: failed to fetch file ‘780c312bebf3e93ba8d0f53bd42f2c49’ (build config) (flags = 0x0): E_IO_ERROR
[20211111T14:40:55] {1935169} ERR: failed to fetch build configuration file: E_IO_ERROR

So, maybe it’s a CDN error? A permissions error? (Setting that folder to the yolo mode of 777 does not help the launcher in any way, sadly.)

Anyway, it’d be great if a fix were found. Good luck to everyone! :slight_smile:

2 Likes

Having the same exact issue on my windows. Tried every suggestion as well. Relieving to see its just not me tho

4 Likes

Same issue, MacOS 10.15.7.

1 Like

Same issue, MacOS 11.3.1

same issue OS 12.0.1 played about 6 hours ago. went to store and now I cant update or play cuz I am not the administrator but I am. Please fix your broken program that we pay for!!!

5 Likes

Also having this issue. Just updated OS to 12.0.1 Monterey. Please fix ASAP!

2 Likes

On my Macintosh the Battle.net program says I need to Update. I press Update and it says Agent wants to make changes, asking for my password. I enter my password and press OK. Battle.net displays an error dialog saying I need to try again after logging on as an administrator – but I am logged in as an administrator. BLZBNTAGT00000841

I am on macOS 11.6 Big Sur. An iMac Pro (2017).

I was able to log in and run WoW about 4 hours ago. There was no Update indication at that time.

UPDATE: I deleted Blizzard-dot-net and World of Warcraft, pulled down Battle-dot-net-Setup-dot-zip and setup up fresh, and re-installed WoW. I was able to get in.

2 Likes

Same issue trying to update retail WoW. Thought it was an Agent-related issue and tried everything from this article but nothing helped. Deleting Battle.net Files - Blizzard Support

Also I have not yet updated to Monterey; I wasn’t sure if installing that would resolve the problem but from the other comments here it seems to not make a difference.