Boot loop fix? anyway around this?

Is there a fix for the boot loop? I am asked to update, says network upgrade failed and restarts the process again. All my ports on my router are fwd’ed correctly.

1 Like

Boot loop? The network ports wouldn’t affect the game simply opening.

What is the boot loop you’re talking about?

Connecting to bnet it says game needs to be udpated. I update it then it closes and the blizzard updater shows up ver 2.24 and says this program is used to update programs through and does not need to be run. And starting the game again goes through this exact same process. All my ports are fwded correctly. Game just will not update.

Ah ok.

So far I haven’t seen anything official.

Are you able to take a screen shot of your port forwarding settings? You can upload the pic to an online sharing site, then post the link to it here.

The link will to be formatted in order to post it here. Once you paste the link, use the “Preformatted text” option on it. That’s the </> symbol in the tool bar. It will look like:

The reason I ask is because you may need to also set your computer to a static IP for it to work.

My port fwding settings are correct on my hardware firewall and windows firewall. Nothing is wrong with me connecting to bnet…its a loop of an update I am in. Has nothing to do with networking. Like I said, fwding ports are very easy. I am 48yo and been doing this stuff since 15. Plus I am too lazy to do something that is literally 100% correct.

My computer has a static IP for its LAN address. Nothing is changing behind NAT it’s all static. Again this issue is not me connecting to bnet at all. I can connect fine. It won’t update correctly and goes back to wanting to update it.

The thing is, it shouldn’t need to update. The most recent version is what Bliz is providing. As such, my copy didn’t require any update when I first connected to Battlenet. Something is blocking that version info from Battlenet when you try to connect.

I asked because someone with the same update loop issue solved it for themselves via network settings. I was trying to see if what you have matched them. If you don’t want to try that, it’s your prerogative.

The only thing I can think of as a work around is to find a standalone patch installer for the version that Bnet is currently using. Run it separately and if it completes successfully, try again.

Good luck.

What was the fix for the other persons loop issue with network settings?

What fixed it via his network settings? I have free and clear no barriers network wise to bnets servers. But please tell me what that person did to fix his issue. Thanks.

I have udp and tcp 6112 to 6119 forwarded to my local desktops ip. I am using external port forwarding. Nothing internal.

Port Forwarding List (Max Limit : 64)
Service Name	External Port	Internal Port	Internal IP Address	Protocol	Source IP	Edit	Delete
diablo 1	6112:6119	BOTH		
blizzard downloader	6881:6999	BOTH		
blizzard downloader	3724	TCP		

.227 is my desktops lan reservation ip. The colon between ports specifies a range on my router.

Here’s what they posted after a few days if trying different things.

I already stated that I have lan reserved IP address. This is basic 101 networking. This has all been done and is 100% correct on my end. Also I have rebooted my router, pc and cable modem. Nothing is in the way.


Something else to watch out for is the small Window that pops up when an application is trying to connect to the internet for the first time. The one that has check boxes for Private and Public connections. It can often pop up behind other windows.

When I was first launching WC2, it wouldn’t connect until I selected and confirmed the setting.


The box has already been allowed. I have already confgured the windows firewall to allow full access to the .exe and also the port range.

Yes, I get it, jarablue.

Everything you have done, I have done. And like PieceofPanic, it’s working for me, so it’s not a universal issue. Something about some people’s system environments is conflicting.

Thus, in this case, you may have to wait to see what comes of it.

Lev: Did you cancel out the update message? Or did you ever see it at all? (You mentioned you didn’t need to update the game.)

Never saw it. Nothing that referred to an update appeared (for either WC2 or D1).

I only saw the port error window, which is expected, before I forwarded the ports.

That means your system is configured in a way that many others’ are not.

I didn’t ever get a port error message. Only the update. I didn’t have the ports configured on first launch either. Even after doing the ports, I still get the update and it just loops.

Agreed. There’s something about some people’s system environments that is conflicting with the multiplayer mode of the game(s).

It’s possible that you don’t see the port error because you’re not making it that far in the process. The update is likely before the port check step.

EDIT: I re-read what you wrote above. You didn’t have the ports configured first either, but still didn’t see an update message.

Even after doing the ports, I still get the update loop. So, the information never gets past that update message to run the game.

BTW, it says everytime, that it updated successfully.

I launched first, got the ports error, closed, then forwarded the ports, then launched again. It didn’t result in an update loop.

The thing that’s strange is that there shouldn’t be any update. The copy that is downloaded via the launcher is the current version.

Right. I made an edit to my above message to correct that.

Again, your system is configured in a unique way somehow. A lot of folks are getting that update box first and getting caught in that loop .

In-game Diablo 1 message box says:

“There is a new version of software available. requires that you use the latest version. Your software will be updated now.”


On Windows desktop a MSGbox:

Blizzard Updater v. 2.24
“This program is used to upgrade programs through and does not need to be run.”

Yeah, that last message is generated by a file called “BNUpdate.exe”. I suspect that it’s obsolete now that the launcher is used to keep games up to date.

Sorry if this is dumb question: Are you using the version that downloads through the modern launcher (the BDA)? Or a previous, old install that downloaded through the old standalone installer?