Warcraft 2 B.Net Online

Tried to play it online, got Port 6112 UDP error - forwarded ports & didn’t resolve issue.

Any plans for this to work online soon?


Wondering the same. I pretty much have a new issue every time i try to play wc2 online after buying it two days ago. Still unable to play, i have a ticket open though.

1 Like

Did u make sure ur PC has a static IP/DHCP?

  1. Log into your Router by typing in the default IP into your browser(The IP is usually on the back of the router, together with username/password).
  2. Add device(the pc your playing from) into static DHCP.
  3. Go into network setting → NAT → Add Port Forward.
  4. Enter your WAN IP(make a google search “what is my wan ip”), Server IP address(The static DHCP, from step 2), Port:6112-6119, change to TCP/UDP and activate and add/save.
  5. Pull out your Ethernet cable and plug it back in.

That should be it.

I was just checking out Warcraft 2 battle net, with a couple of people I met in the chat, that too works flawlessly.

Edit: Corrected info in step 4!!! As of today, both static DHCP and Default IP address.

To anyone who sees chayliss’ post above

The version being sold by Bliz DOES have multiplayer on Battlenet and there IS a Gateway to play on.

For some reason i cant change into dhcp on my router.

I would have hoped blizzard would have seen this issue prior to taking money. But well. Nope

It might be called static IP or IPV4 I in other routers.

1 Like

Most home routers come with DHCP enabled by default. If you are trying to make your gaming computer’s IP permanent, you would change it to a Static IP.

its possible you are not using IPV4, same as me, you cant do anything if your ISP dont have it

Ports are something on a router. And home routers should be using IPv4 for the LAN, meaning it your ISP wouldn’t come into play.

I’m using IPv6 between my ISP and me, but my home LAN is IPv4. There’s not even an option on my router to use IPv6 for the LAN.

Do you not use a router on your home network?

1 Like

DHCP refers to Dynamic Host Configuration Protocol, which is the network management protocol for IP’s internally. You don’t need to “change INTO DHCP”, you add your device’s IP to the static DHCP group. or “turn on static IP”.

-Usually it’s just checking a box once you open the infoscreen of your Desktop, inside the routers network Status.

it’ll say something like this example:
“IPv4 Address:
□ Add device into Static DHCP”

Then u check that box, remember the IPv4 address, and fill that into your your port forwarding, as the “server IP”.

Edit: It’s not actually gonna be, that was just for the example.

Where? I have gone through all troubleshooting steps listed above and have yet to be able to enter any server.

Any luck? I’ve gone through all the troubleshooting steps to no avail

If you are using a router as part of your home network, you need access it via your web browser. For Linksys routers, that’s usually Netgear routers are usually However that can vary. You’d have to research your router make and model model if those don’t work.

After that, I’d start with the article link in this support article:

You can start with just forwarding the required ports. Then if that doesn’t help, try the static IP setting that PieceOfPanic is suggesting.

1 Like

No, no. I have already done this. I’m saying where are these servers you are talking about. I have done everything mentioned and I cannot make it passed the login screen on Battle.net. I either get a “You cannot enter the server with this account” or “Incorrect Password” when I have very clearly typed the correct password. I have tried making multiple accounts now. No success

Oh, you haven’t made it past logging in.

By chance, did you try to log in multiple times in a short span of time?

EDIT: I’m getting the the same error now as well when I try to log into WC2. Perhaps something is going on on the server side. What makes me think so is that new accounts can’t be created either.

So this sounds like it’s not on the player’s end. We may need to hang back and see if it resolves.

Ok, now I’m confused. What?
So you have a login/account issue?

But not UDP error or anything else?

-The “server” I’m talking about, is a setting during port forwarding inside your router settings(Not in the game). It might be called different things in different routers. e.g.
Internal IP, Local IP, Server IP, Static IP, IPv4 etc.

EDIT: I too am getting this error on Warcraft 2 battlenet, Diablo 1 works still though.

Plug your internet cable into your wall dont plug it into router and you are fine to go. then you dont need open ports.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.