Battle.net Launcher asking for admin -- cannot update WoW

Hi,

I hope this is all right. I wanted to cross-post this thread from the Desktop App Tech Support forum, as it’s mostly Mac users (like myself) who are having these issues.

In short, the Battle.net Agent keeps asking for admin privileges and WoW cannot update. There are some debug messages in this post, and some other bits of relevant info. Thank you!

2 Likes

Same has just hit me.

I have looked up Blizzard suggestion.

  • Full restart. Same issue.
  • Clean up of \Users\Shared\Battle.net. No.
  • Remove \Users\Shared\Battle.net. No.
  • Uninstall Battle.net, remove all library and cache folders/files. Download installer. Restart and install completely fresh version. No.

I can run World of Warcraft stand alone app. I can login just fine (though I assume it’s not updating). Has some combo of new OS and Blizzard update screwed something?

Note: As an update I thought I might have found the issue. Battle.net seems to update just fine other installed apps on my Mac (Hearthstone, DIII, Warcraft III, StarCraft II, Heros of the Storm) It’s just failing and asking for Admin rights with WoW and WoWC.

I investigated and found that my World of Warcraft directory had the security rights owner set to “system” and all the rest were owned by “Me”. That directory contains both versions of WoW. I set me as owner, fully uninstalled Battle.net again. Rebooted. Installed. Authenticated. Nope. Issue remains. … Damn.

Need a clue here. My next recourse will be full uninstall of WoW and WoWC and full reinstall.

Same problem for me, except that I cannot even run WoW as a standalone app any more, because that has been broken for a week now.

Tried pretty much everything, with the exception of a full reinstall.

Same problem that me this morning. It happens to me 5 minutes after downloading new Addons versions.

Hi Idoru, did you have a reply from Blizzard customer service concerning our BIG problem?

Having the same problem here! I am logged in as the admin. It’s obviously bugged. Fix it Blizz!

I’ve just managed to fix my install on macOS 12.0.1 and it appears that something, possibly the updater which checks permissions, removed the ‘x’ attribute from folders under Data, x or execute on UNIX controls folder access if applied to a folder.

To fully fix I used these commands but use at your own risk of course.

# This seems to be the thing that is causing the updater to ask for user ID every startup
# and seems to get reset to root owner on a fix permissions
sudo chown $(whoami) /Users/Shared/Battle.net
# This fixes the folders from drw-rw-rw to drwxrwxrwx
sudo chmod 777 '/Applications/World of Warcraft/Data/*'
# I found some of my files were owned by root and not me, this fixed those
sudo chown -R $(whoami) '/Applications/World of Warcraft'

EDIT: Note that the Battle.net folder keeps getting reset to root ownership causing the popup on startup of the launchers. Hopefully this will get fixed soon and the patch process will start applying correct folder permissions.

4 Likes

Wish I’d thought to update rights to EXECUTABLE as well is returning ownership to me.

Anyway, I took the burnt earth option and uninstalled/reinstalled. After Uninstall I still could not get install to start till I removed the “Retail” folder. After that it started straight away. Then it was just download/install ~77GB of data and I was up and running again.

Rights have remained with me as well and have not reverted to SYSTEM

It worked for me. I just went to the world of warcraft folder into the application folder and changed the permission of the data folder to read and write for all and applied to the enclosed itens …

gg

Same thing here; constantly asking for admin password. Functions fine after that for me, but it’s pretty annoying and seems unnecessary.

Hey there,

No new updates from our Dev/QA team. I just wanted to check in with y’all. If you are impacted by this issue and have not posted on this forum regarding the bug please do so. Our support staff will add you to our tracking of the bug.

If you have posted already, it should be fine to leave it at that until we are in the “retest” phase. I’ll post on this thread once we have more updates!!

Thanks for reaching out to us. Cheers!

1 Like

I’m having the same issue, except I couldn’t launch Warcraft at all, even from the application folder. I uninstalled the game, thinking that would help, and now can’t even get it to download and install.

Same issue. Did a full uninstall of everything and still need ‘admin’ privileges. It DOES have them, I did everything uninstalled EVERYTHING battle.net / blizzard related and deleted, but still nothing. Now it just loads forever (the battle net symbol) or says it needs admin privileges.

1 Like

Same issue, can’t run the game.

Actually, while I am having the same issue it is for Warcraft 3 not wow, but oddly enough every time I exit wow it starts reupdating both retail and classic wow.

1 Like

Hello, I had this issue today. After putting in a ticket and trying all suggestions, I found the problem. It was a read/write permission for the bnet folder. You MUST click the three dots and actually choose to APPLY the read/write permission for admin. Ugh!

I am having the same issue - have tried applying the permissions to all of the folders I can find - what was the name of the folder that made it work for you?

Same Issue on my Mac - I was on Big Sur, so I updated to Monterey hoping that would help. I have tried everything… I hope there is a resolution soon. :frowning:

Count me in as having this same issue. I’ve checked my permissions and they’re read & write for everyone for the folders mentioned in the above comments. I’ve removed the Agent folders as recommended by others and still I can’t get the updater to get past 0%. You might want to update the Blizzard’s tech support because Fix Disk Permissions isn’t an option anymore in the newer MacOS versions (nor can you use terminal commands apparently). Things worked for me on Thursday night (EST) but not since Friday and I haven’t changed things on my end. All weekend without WoW…and a week before my subscription is up for renewal…and your company’s current culture problems…and this isn’t the first issue Mac Users have faced and spent DAYS waiting for fixes while PC users go about their playing…Please do better.

Same issue here. Tried to give Full Disk Access to both Battle.net app and the Agent.app applications, I am running everything on an admin account, added the different agent.app apps from Shared folder as well, and manually added admin read/write ability. It still asks me for admin password at the beginning of the “update” cycle but never actually manages to push through or pass the 0% mark.