Battle.net desktop app - cant install any game

After installing the battle.net desktop app when I go to install any game I get stuck at the install screen. For example, when I try to install COD: MW I get stuck at the screen “Call of Duty: MW Installation” popup with the loading indicator in the bottom right spinning indefinitely.

I feel like I have tried everything I could find on this forum with no luck. I’ve also reinstalled windows.

Looking for help with how to resolve this issue.

Tech Specs:

  1. iMac Pro running boot camp
  2. Windows 10 - Fresh install
1 Like

I have the exact same issue, or atleast did.
For me the issue is now after waiting an extremely long time on this loading screen to be able to click start install it now just hangs indefinitely on ‘waiting…’ for several hours.

Reinstalled the Windows Bootcamp several times.
Reinstalled battle.net several times with many issues.
Reinstalled wow directly and that just didn’t work at all.

I tried looking to network issues but other applications seem to install just fine.

im running win 10 on pc and that infinite “waiting” also happening to me…
blizz use to have it better back in the days, this client sucks