[Vlader] app stuck spinning

I’m with exactly this problem and Blizzard doesn’t do nothing to fix. Horrible launcher, the worst I’ve used. I tried everything I found in the internet to fix.

Howdy Vlader,

These issues can be caused by several different problems and it’s difficult to pinpoint exactly what’s causing the problem in your situation. The most common cause I’ve seen though is simply not having any of the game options selected. To double check this, click Modify Install and make sure everything you want is checked. If this doesn’t help, please provide a screenshot and a full list of steps you have already tried. Also include a DxDiag:

  1. Press Windows Key + R.
  2. Type DxDiag and press Enter.
  3. In the DxDiag window, click Save All Information.
  4. Name the file “dxdiag” and click Save
  5. Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the “preformated text” button (</>). That’ll make the information much more readable.
It should look like this.

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

You can upload the screenshot to a site like Imgur.

Hello, thanks for the reply!
I’m stuck at the spinning Battle.net logo after clicking the button to start installation of any game. I’ve already tried:

  • Reinstalling Battle.net;
  • Deleted all Battle.net and Blizzard folders at ProgramData, AppData and Temp;
  • Disabled Antivirus;
  • Started Battle.net as administrator;
  • Tried with the Beta version of Battle.net;
  • Tried use Battle.net with ExitLag to change net routes;
  • Unchecked Proxy server from Windows Control Panel;
  • Tried in CMD the commands “netsh int ip reset C:\resetlog.txt”, “netsh winsock reset” and “ipconfig /flushdns”;

Here’s screenshot of the problem:
imgur (dot) com/a/cMLLNN5

Here’s the DxDiag:
pastebin (dot) com/rXdUh8Dm

Howdy Vlader,

It looks like you are trying to play for free however I don’t see a Date of Birth being added. Let’s go through these steps:

  1. Close the application completely.
  2. Launch the Blizzard App and sign-in.
  3. Go to “Call of Duty: Modern Warfare” page and press “Play for Free”
  4. Enter Date of Birth
  5. Start Installing again
1 Like

Hi, I added the date of birth in the first time I tried to install, now doesn’t show this option anymore. I tried these steps, but never works the installation… Games not +18 like Overwatch or Hearthstone is also not installing. I’m trying to install any game for almost three days, and I can’t in any way I try. I’m really frustrated and upset with this launcher. I paid for the Overwatch and I can’t play anymore… As a developer, I’m so impressed that something so simple as downloading a game seems to be a common problem for years, as I found out in the forum.

Hey there Vlader,

We appreciate you taking the time to reach back out to us with that information, and I am sorry to hear of the ongoing problems installing Overwatch. Considering the steps that you’ve tried so far have had no impact, can you temporarily test an alternate network such as a mobile hotspot or VPN? This will help us quickly determine whether the issues are network-related.

1 Like

For anyone having this issue, my battle net app would not progress once I clicked “Install” for any blizzard game through the battle net app. I would click install, the window would pop up where it should give me options to install, etc. but it would be blank with blizzard logo spinning on bottom right. Turns out… it was ASUS Gamefirst VI which is a network optimizer… As soon as I closed this app the install worked flawlessly. So be sure you don’t have something like this running as it affects the network accessibility of applications. I actually think the blizzard install servers didn’t “like” this app and could have conflicting permissions or security issues between them.

1 Like