API missing certain mounts for some characters

Hello! I have gotten reports that some characters are missing mounts when viewing their collection. We have looked into it a bit, and it seems to be a bug with the new Profile APIs… the old Community APIs seem to work. As such, the mounts are missing from WoW’s official armory page as well. These mounts seem to work for some characters but are broken for other characters, and we are not sure of the pattern.

The missing mounts are:

  • Shadowbarb Drone (ID=1320, SpellID=316339)
  • Vicious White Bonesteed (ID=1197, SpellID=281889)
  • Vashj’ir Seahorse (ID=373, SpellID=75207)

Some example characters:

  • profile/wow/character/frostmourne/kelly/collections/mounts?namespace=profile-us
    • All 3 mounts are missing but this character does have them collected. You can see them in wow/character/frostmourne/kelly?fields=mounts
  • profile/wow/character/drenden/shoogen/collections/mounts?namespace=profile-us
    • Vashj’ir Seahorse is missing. Shadowbarb drone appears to be working. This character does not have the Vicious White Bonesteed. You can compare against wow/character/drenden/shoogen?fields=mounts

These are just two examples but I have heard other players are having this problem as well. If needed, I can run some scripts to try to get a more thorough list of who is working and who is broken. Thank you!

1 Like

I would also add that this is not specific to mounts. I’m missing some battle pets as well. Namely Reek, Void-Scarred Toad and Rotbreath.

To me the pattern seems to be if you obtained them the first few weeks, you have them collected. But if you collected them recently(within the last two weeks) you don’t. Although that theory may be easily refuted. At least for the new(8.3) collectibles.

1 Like

Here are the API calls that show Gaulish’s missing pets:

  • profile/wow/character/bloodscalp/gaulish/collections/pets?namespace=profile-us
    • Notice that Reek (ID=2844, CreatureID=161967), Void-Scarred Toad (ID=2796, CreatureID=160187), and Rotbreath (ID=2847, CreatureID=161997) are missing
    • Compare to the old API which shows them as collected: wow/character/bloodscalp/gaulish?fields=pets

I collected Reek today, and it is properly showing in my pets:

  • profile/wow/character/drenden/shoogen/collections/pets?namespace=profile-us

So that might debunk the two week theory, but clearly something is going on that it works for some characters but not others. Thanks!

Thanks for the reports. We’ve seen some of these reports in the API Bug Report forums as well! We’ve been able to look into them a bit since. Here’s what’s going on:


Character Mounts in the Profile API currently only tracks mounts that are acquired at the account level as opposed to the character level. In that respect, the endpoint will currently return the same result as the /profile/user/wow/collections/mounts endpoint. Any mount that’s acquired on a per-character basis will exhibit this bug. This includes class-specific mounts, PvP mounts, and some special case mounts like the ones you’ve mentioned.

We have a bug tracking this internally, and we’re working on a fix.


Character Mounts and Character Pets in the Profile API update on account logout as opposed to character logout. (This also applies for the /profile/user/wow endpoint and any user sub-endpoints.)

An account logout involves either quitting the game (via closing the WoW executable) or logging out of the WoW client (e.g. via the “Back” button on the character select screen) from all WoW accounts on a Battle.net account. Logging out of your character to character select or realm select does not suffice. You must be logged out of all WoW accounts at the same time to trigger the event.

The update times for the above user indicate that character logouts have occurred, but an account logout has not. Could you perform an account logout and see if that fixes the issue?

1 Like

This sounds like a potentially serious problem for me. My two week time frame came from when I noticed my pets/mounts not being updated, and I sure as hell have not been logged in for two weeks straight. So either someone has been using my account(and I haven’t noticed) or something else is going on.

To be sure I logged out of Bnet completely, restarted the computer, and still the website shows the pets as uncollected.(Ie an account logout has not been performed yet)

Edit: The more I think about it, it is very likely that the first time(in this two week window) I tried to trigger a character refresh/api call on Data for Azeroth, one or more accounts was still logged in.(Because I forgot about this account logged out rule). So maybe the api got stuck or something when trying to do subsequent refreshes/api calls, even with all accounts logged out.

Thank you for the follow-up! I am glad to hear this bug has been tracked, I greatly appreciate it.

I have just gotten a report of the “Solar Spirehawk” being missing, which I believe is just a regular account-wide mount and does not seem to fit the case you described. Though maybe it falls under a special case? But I wanted to provide it as an additional example to possibly help your debugging.

  • profile/wow/character/ravencrest/shewy/collections/mounts?namespace=profile-eu
    • Notice that Solar Spirehawk (SpellID=171828), Uncorrupted Voidwing (SpellID=302143), Wastewander Skyterror (SpellID=316276), and Vashj’ir Seahorse (SpellID=75207) are missing.
    • Notice that these mounts do correctly appear when using the old Community API: wow/character/ravencrest/shewy?fields=mounts

Similarly, based on Gaulish’s response, I am concerned that something else may be going wrong. Perhaps exiting an account is not properly updating the APIs as expected? But I don’t want to speculate too much and leave it to the experts. Thank you so much for your help!

We believe this issue is resolved with the bug fixes mentioned in the Patch Notes this week. Affected users will need to perform an account logout after this week’s weekly reset in each region.

Let us know if you’re still seeing issues. :smiley:

1 Like

Thank you Araspir for the follow-up! Unfortunately, so far it looks like the bug is still happening. I don’t have the ability to contact all my users, but I was able to get in touch with one and asked them to perform an account logout. It seems that mounts are still missing compared to the old Community APIs.

  • profile/wow/character/ravencrest/shewy/collections/mounts?namespace=profile-eu
    • Mail Muncher, Solar Spirehawk, Uncorrupted Voidwing, Wastewander Skyterror, and Vashj’ir Seahorse all seem to be missing
    • These mounts do correctly appear when using the old Community API: wow/character/ravencrest/shewy?fields=mounts

If I hear back from other users I will try to let you know. Thank you for your continued help with this issue!

Edit: I have just heard back from another user and they confirmed the bug does not appear fixed for them either.

  • profile/wow/character/frostmourne/kelly/collections/mounts?namespace=profile-us
    • Shadowbarb Drone, Uncorrupted Voidwing, Vicious White Bonesteed, and Vashj’ir Seahorse all appear to be missing
    • The old community API does show these mounts: wow/character/frostmourne/kelly?fields=mounts

Thank you again for your help with this issue!

This is my bad! I totally misspoke.


The Mounts issue mentioned above has not been fixed yet. We still have a bug internally tracking this.


The Pets issue mentioned above was a result of a separate bug in which character information and account information on accounts with too many characters would not update properly. That bug has been resolved.

I’m sorry for the confusion!

I’m not sure the pets are fixed. I just checked and they are still showing as uncollected on the wow website. I was logged out for a few hours before I checked so it should have registered an account logout today, if the patch was this morning.

I do qualify as a person with too many characters I would imagine.


Thank you! I know I had mentioned this before, but just to make sure, mounts like Mail Muncher and Solar Spirehawk are not working right now either. These seem to be normal account-wide mounts? So while I understand that bug with per-character mounts hasn’t been fixed yet, it still seems like something else is going wrong.

Combined with Gaulish’s report that pets are not working either, it feels like account logouts are still not quite working right for some users.

Thanks again!

Edit: As of this morning (Mar 5) Both Kelly and Gaulish (US) have let me know that things seem to be working now! However, Shewy (EU) is still not. I assume it takes an extra day for patches to get rolled out to EU, but just thought I would mention it here to be sure. Thank you!!

Edit 2: It looks like Shewy is now working as well. Thank you, thank you, thank you!

Just want to report that Vashj’ir Seahorse is still not reporting as collected for Melisan-Draka.

I understand that the above mentioned character level mount bug has not been announced as fixed, but I am confused as to why this mount does show for many (even most), but not the above character. From the description, the listed character level mount bug sounds like it should be universal.

One possible thing I could imagine that might be a factor for this character (Melisan-Draka) and the Vashj’ir Seahorse, is that it was transferred from Alliance to Horde after completing the associated quest. Yet, I do not see that this quest or mount as having different IDs for each faction.

1 Like